Find the answer to your Linux question:
Results 1 to 6 of 6
Dear all, I'am strugling with becoming root on a system which boots over a network (PXE) and uses the Knoppix Terminal Server which is running on a different computer. Booting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    3

    [SOLVED] Root password in Knoppix Terminal Server


    Dear all,

    I'am strugling with becoming root on a system which boots over a network (PXE) and uses the Knoppix Terminal Server which is running on a different computer.

    Booting the other computer via the network works perfect and Knoppix 6.2 is loaded within a few minutes.
    However, when I try to become root (using "su" or "sudo su" command) it askes for a password, although I did NOT set a password (also not on server).
    Also by trying to access to root terminal via the menu it asks for a password....

    Can some help me solving this issue.

    Thanks in advance for your replies.

    Cheers
    Marcus

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    does
    Code:
    sudo -s
    work?

  3. #3
    Just Joined!
    Join Date
    Dec 2009
    Posts
    3
    Quote Originally Posted by Jonathan183 View Post
    does
    Code:
    sudo -s
    work?
    @ Johanthan183:
    Thanx for ur suggestion, just tried but it does not work unfortunately and gives the same message that it requires a password to become root.

    I have no clue what this password should be, I also tried setting a root password at the terminal server, but when I type this password in the client it says that the PW is wrong.....

    Any other suggestions are welcome?
    How can I set this root password for clients???

  4. #4
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    Live CD boot should have no password and should not prompt for one ... check what commands you are able to run as current user with sudo -l

  5. #5
    Just Joined!
    Join Date
    Dec 2009
    Posts
    3
    Quote Originally Posted by Jonathan183 View Post
    Live CD boot should have no password and should not prompt for one ... check what commands you are able to run as current user with sudo -l
    Thanks for your help....

    I found a workaround....I used terminal server to start memdisk and launch the iso file of the knoppix disk. This gives me the normal version of knoppix on the client machine (so with sudo access).

    Cheers

  6. #6
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    Glad you got things sorted ... can you mark the thread as solved as this may help others with a similar issue in future

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •