Find the answer to your Linux question:
Results 1 to 6 of 6
Hey guys! Quick rundown, our laptop has us between a rock and a hard place.. one being Safeboot and the other being stuck in Safe Mode with some unholy WinXP ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3

    [SOLVED] Unable to mount drive


    Hey guys! Quick rundown, our laptop has us between a rock and a hard place.. one being Safeboot and the other being stuck in Safe Mode with some unholy WinXP Admin password prompt not letting us by .. anyhow, to the Knoppix lol:

    Using Knoppix 6.2

    Microknoppix:/home/knoppix# fdisk -l
    Code:
    Disk /dev/sda: 40.0 GB, 40007761920 bytes 
    240 heads, 63 sectors/track, 5168 cylinders 
    Units = cylinders of 15120 * 512 = 7741440 bytes 
    Disk identifier: 0x39133912 
    
       Device Boot      Start         End      Blocks   Id  System 
    /dev/sda1   *           1        5167    39062488+   7  HPFS/NTFS
    Microknoppix:/home/knoppix# mount
    Code:
    rootfs on / type rootfs (rw,relatime) 
    proc on /proc type proc (rw,relatime) 
    sysfs on /sys type sysfs (rw,relatime) 
    /dev/sr0 on /mnt-system type iso9660 (ro,relatime) 
    tmpfs on /ramdisk type tmpfs (rw,relatime,size=1048576k) 
    /dev/cloop on /KNOPPIX type iso9660 (ro,relatime) 
    unionfs on /UNIONFS type aufs (rw,relatime,si=1be31434,noplink) 
    unionfs on /home type aufs (rw,relatime,si=1be31434,noplink) 
    usbfs on /proc/bus/usb type usbfs (rw,relatime) 
    tmpfs on /UNIONFS/var/run type tmpfs (rw,relatime,size=10240k) 
    tmpfs on /UNIONFS/var/lock type tmpfs (rw,relatime,size=10240k) 
    tmpfs on /UNIONFS/var/log type tmpfs (rw,relatime,size=102400k) 
    tmpfs on /tmp type tmpfs (rw,relatime,size=1048576k) 
    udev on /dev type tmpfs (rw,relatime,size=20480k) 
    tmpfs on /dev/shm type tmpfs (rw,relatime,size=1048576k) 
    devpts on /dev/pts type devpts (rw,relatime,mode=1777)
    Microknoppix:/home/knoppix# cat /etc/fstab
    Code:
    # DEFAULT BASE FSTAB, UNCONFIGURED 
    proc       /proc         proc       noauto             0 0 
    sysfs      /sys          sysfs      noauto             0 0 
    # Added by KNOPPIX 
    /dev/sda1 /media/sda1 auto noauto,users,exec 0 0 
    # Added by KNOPPIX 
    /dev/sr0 /media/sr0 auto ro,noauto,users,exec 0 0
    Any input would be greatly appreciated. I would be more than happy just to reinstall a new OS, but I would hate to tell my girlfriend I lost all of her pictures lol

    Thanks!

  2. #2
    Just Joined!
    Join Date
    Oct 2009
    Posts
    18
    assuming Knoppix created a directory /media/sda1. You will need to be root in a terminal try
    Code:
    mount -t ntfs /dev/sda1 /media/sda1
    If the directory /media/sda1 was not created then you can do in terminal
    Code:
    mkdir /media/sda1
    and then retry mounting sda1. Just a thought on the safemode password I had this problem with Windows at some point where it prompted me for a password I tried everything then finally I just hit enter when prompted and it turned out the password was empty, just a thought. Good luck

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    If you want write access in NTFS Partition(s) then use ntfs-3g instead of ntfs.
    Code:
    mkdir /media/sda1
    mount -t ntfs-3g  /dev/sda1 /media/sda1  -o defaults,umask=0
    umask=0 will allow Regular Users to read/write NTFS partition(s).
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #4
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3
    Hey guys, thanks for the super fast responses! I did both suggestions, and used the Root Terminal, this is the end product:

    Code:
    oot@Microknoppix:/home/knoppix# mkdir /media/sda1
    mkdir: cannot create directory `/media/sda1': File exists
    root@Microknoppix:/home/knoppix# mount -t ntfs-3g /dev/sda1 -o defaults,umask=0
    Usage: mount -V                 : print version
           mount -h                 : print this help
           mount                    : list mounted filesystems
           mount -l                 : idem, including volume labels
    So far the informational part. Next the mounting.
    The command is `mount [-t fstype] something somewhere'.
    Details found in /etc/fstab may be omitted.
           mount -a [-t|-O] ...     : mount all stuff from /etc/fstab
           mount device             : mount device at the known place
           mount directory          : mount known device here
           mount -t type dev dir    : ordinary mount command
    Note that one does not really mount a device, one mounts
    a filesystem (of the given type) found on the device.
    One can also mount an already visible directory tree elsewhere:
           mount --bind olddir newdir
    or move a subtree:
           mount --move olddir newdir
    One can change the type of mount containing the directory dir:
           mount --make-shared dir
           mount --make-slave dir
           mount --make-private dir
           mount --make-unbindable dir
    One can change the type of all the mounts in a mount subtree
    containing the directory dir:
           mount --make-rshared dir
           mount --make-rslave dir
           mount --make-rprivate dir
           mount --make-runbindable dir
    A device can be given by name, say /dev/hda1 or /dev/cdrom,
    or by label, using  -L label  or by uuid, using  -U uuid .
    Other options: [-nfFrsvw] [-o options] [-p passwdfd].
    For many more details, say  man 8 mount .
    root@Microknoppix:/home/knoppix#
    I can see the media/sda1 and media/sr01 folders in the PCMan File Manager, but they're both currently empty
    My main goal I guess is just to get where I can edit the boot.ini and remove the safe mode manually, if that helps at all.. really appreciate this btw!
    Last edited by Nomad33404; 01-16-2010 at 05:51 PM. Reason: new info

  5. #5
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3
    Ended up resolving this issue. My drives weren't being detected due to the encryption put on them from McAfee Endpoint Encryption (aka SafeBoot). The encryption was also what was preventing me from resetting the WinXP passwords.

    For anyone who comes across this issue in the future, here is what I did (I had the SafeBoot user password, but no disks to uninstall):

    Download WinTech (google for the ISO and use a program such as imageburn to make a bootable copy)

    You will need to Authorize and Authenticate it, so you will need the SafeBoot user login PLUS the 4 digit daily code from McAfee (McAfee wouldn't give one up, so I googled for an old code and changed my computers date in WinTech to the date of the old code, it actually worked lol)

    Set the disk algorithm and go to Remove Safeboot.. about an hour later, I rebooted and could see my drives sitting pretty in Knoppix.

    I changed the boot.ini, deleted the /safeboot minimal and Viola! Everything was back to normal lol. Anyhow, it was an odd situation I found myself in, but at least this info is here for the future lol.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    root@Microknoppix:/home/knoppix# mount -t ntfs-3g /dev/sda1 -o defaults,umask=0
    You were executing wrong command. As I suggested earlier, correct command is
    Code:
    mount -t ntfs-3g  /dev/sda1 /media/sda1  -o defaults,umask=0
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •