Find the answer to your Linux question:
Results 1 to 3 of 3
I am having same/similar problem. I am trying to install Knoppix onto an older HP. Both the live cd and install dvd get to the same point - could not ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Posts
    15

    Question Knoppix will not boot on original pc


    I am having same/similar problem. I am trying to install Knoppix onto an older HP. Both the live cd and install dvd get to the same point - could not mount disk to /mnt-system Starting debugging shell. I moved the hd and dvd drive to a different PC and ,using the same dvd, I was able to install Knoppix onto the hd. Moved things back and now Knoppix will not boot on original pc. The same hd booted fine several times on the other pc.
    DVD is good.
    DVD drive is good.
    HD is good.
    Ran memory checker for hours - no problem. Memory is good.
    Question 1 : What is Knoppix trying to do at this point? I have tried to issue mount commands for dvd drive and hd. Fail with invalid argument
    Question 2: What can I run at this point to determine why it is failing?

    Note: Live Cd and install dvd fail in the same way at the same point

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    when you boot up in live environment, can you see the HD?

    there is a chance the connection to the HD in this machine is bad

    boot up live environment, open terminal and post output of fdisk -l i'm not sure if you need sudo, or su to root on knoppix, but that command must be run by root user

  3. #3
    Just Joined!
    Join Date
    Nov 2007
    Posts
    15
    I entered the fdisk command. Not wanting to risk copying something wrong, I took a picture of the screen with the output of the fdisk and some attempts at mount commands.

    It looks to me like the mount command is not functioning properly at this point. How can I determine why the mount command is rejecting my commands?
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •