Find the answer to your Linux question:
Results 1 to 2 of 2
My Gateway Windows XP laptop has stopped booting, and I needed to recover some of my data before reformatting it. The CD drive doesn't work, so I purchased a live ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2010
    Posts
    1

    Booting Knoppix 6.2.1 from a USB on a Windows XP hangs?


    My Gateway Windows XP laptop has stopped booting, and I needed to recover some of my data before reformatting it. The CD drive doesn't work, so I purchased a live version of Knoppix 6.2.1 on a 2GB flash drive to try and boot from there.

    I was able to change the boot order and get it to recognize the USB, but I have a problem after that. Initially, I get a UNetbootin loader menu, where the options are as follows:

    Default
    adriane
    knoppix
    fb1024x768
    fb1280x1024
    fb800x600
    memtest
    dos
    failsafe

    I select "knoppix" and I can see the Linux logo at the top left hand corner, as well as all the functions loading. I get to a prompt asking me whether I want to create a file for saving my personal files, and it says I can leave it blank if I want to and skip that step.

    Finally, I get to a black screen with xauth: creating new authority file /home/knoppix/.Xauthority on top, and (==) Using config file: "/etc/X11/xorg.conf" on the bottom, where it hangs for a long time, at least 15 minutes by my last count. I still haven't been able to go beyond that point.

    My question is, what is it doing during that time? Is it erasing the HDD on my laptop because I hadn't specified a file size for my personal files earlier? Is it just frozen? I read elsewhere that it should take no more than 10 minutes to boot into Knoppix, so I got worried when it took so long and nothing changed. The cursor doesn't blink during this time either.

    Is there any other option I can try to boot from? Such as failsafe or Default? Any help is greatly appreciated!

  2. #2
    Just Joined!
    Join Date
    Aug 2010
    Posts
    5
    Finally, I get to a black screen with xauth: creating new authority file /home/knoppix/.Xauthority on top, and (==) Using config file: "/etc/X11/xorg.conf" on the bottom, where it hangs for a long time, at least 15 minutes by my last count. I still haven't been able to go beyond that point.

    My question is, what is it doing during that time?
    That is where it is trying to start the X-Server (the graphical interface). Usually if it hangs at this point you need to boot into text only mode and find out why (if you really need the graphical interface).
    Next time you boot, you should try the failsafe option and see what that does. Usually that puts you in a basic environment without any of your drivers loaded (kinda like Safe-Mode in Windows). That should get you to a command line where we can try more stuff.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •