Find the answer to your Linux question:
Results 1 to 7 of 7
One thing is missing in Knoppix-you cannot change - even if you go to system settings-the keyboard layout, for a different language. Is it a way to do it? Thanks....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2012
    Posts
    6

    Unhappy How can I change the keyboard layout?


    One thing is missing in Knoppix-you cannot change - even if you go to system settings-the keyboard layout, for a different language. Is it a way to do it? Thanks.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hello and welcome!

    I don't run Knoppix so can't test it from my end, but check this wiki page to see if it helps you with this issue:

    Language, Locale & Keyboard settings FAQ - Knoppix Documentation Wiki
    oz

  3. #3
    Just Joined!
    Join Date
    Jan 2012
    Posts
    6
    According to that, I have to go to Control Center,etc. But according to what I have on the DVD 6.7.1, you can only go to Preferences, Local, but it doesn't have "keyboard layout".

  4. #4
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    I haven't used Knoppix in a while. But some LiveCDs give you the chance to change your KB layout during boot.
    Is this no longer the case in Knoppix?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  5. #5
    Just Joined!
    Join Date
    Apr 2012
    Posts
    1
    Quote Originally Posted by mjoln View Post
    One thing is missing in Knoppix-you cannot change - even if you go to system settings-the keyboard layout, for a different language. Is it a way to do it? Thanks.
    I have the same problem.
    I'm running Knoppix 6.7.1 installed to the HDD, and I can't find where is the option for keyboard language.
    Found the "locale", changed the "country" setting, but keyboard language is nowhere to be seen...

  6. #6
    Just Joined!
    Join Date
    Jan 2006
    Location
    Lancashire, England
    Posts
    32
    You can always set the language and keyboard during boot. Also in preferences , it is set during 'local / locale" preferences.
    At Boot add "Knoppix lang= uk" to boot line without quotes for UK key board or equivalent code for any other laguage /locale

  7. #7
    Just Joined!
    Join Date
    Jan 2006
    Location
    Lancashire, England
    Posts
    32
    Yes. Still a boot entry for any subset of key board /languages

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •