Find the answer to your Linux question:
Results 1 to 2 of 2
When I open USBView, the following error appears: Can not open the file /proc/bus/usb devices Verifiy that you have USB compiled into your kernel, have the USB core modules loaded, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2012
    Posts
    1

    Linux Knoppix VMware Player USB Mount


    When I open USBView, the following error appears:

    Can not open the file /proc/bus/usb devices

    Verifiy that you have USB compiled into your kernel, have the USB core modules loaded, and have the usbdevfs filesystem mounted.

    I have found several forums that show solutions, but I don't understand everything. I tried mount -t usbfs usbfs /proc/bus/usb, however it shows mount: only root can do that. I searched for a solution and found that you can change the mount to user. So I tried chmod +s /bin/mount and chmod +s /bin/umount, however both give back the following error message:

    chmod: changing permissions of '/bin/mount': Operation not permitted

    I need to mount the usb in order to save a file to it from the VMware Player and opening it in my main operating system. I have seen people post stuff about adding code to the fstab file, however, I don't understand how and where to add these lines. I have never used Linux before, only reason I am using Linux right now is for Operating System I at Metro Community College.

    Thanks for everyones help on this.

  2. #2
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,991
    In order to change permissions of a file, folder or the like if they already have root privileges is to be a root user and then change the permissions to allow anyone else to use them. The below code should mount just fine:

    Code:
    sudo mount -t usbfs usbfs /proc/bus/usb
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •