Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    No config file found while booting [KNOPPIX 8.1]


    I have come here to summon the High Priests of The Linux Order. My PC is linux-proof. I have tried 3 different live-cd linux distros (Knoppix, Antix, Slax), mounted on my USB-stick with both UNetBootin and Rufus. I have received absurd errors from all of them, finally decided to focus all my strength on Knoppix.
    Thank you for all the support in advance!

    When I boot from the USB-stick, my PC displays something like
    No config file found
    No commands work, no image names that I could come up with (knoppix, knoppix32, knoppix64, memtest, etc.) and generally it is blind to my efforts.

    The funny thing is, when I mark option "Burn as DD image" instead of "ISO file", it starts working a little (displays big letters "KNOPPIX"), but only to display errors in init script (line 1250).

    The USB-stick itself is new and doesn't have any bad sectors (checked just a minute ago). I don't think it's a problem with BIOS settings, everything seems OK there. Checked my ISO image MD5 and it's good.

    MSI Z170M Mortar, Gigabyte GTX 970, i7 6700K

    I'm adding a txt file with RUFUS logs from my current setup.
    Attached Files Attached Files
    Last edited by Adalbert13; 02-16-2018 at 06:11 PM.

  2. #2

    Well, it was surprising...

    The problem is partially solved. All I had to do was to rename some files on USB (tried that before, didn't work, now it worked somehow). The next enemy to conquer in my quest is:
    INIT: PANIC: segmentation violation! sleeping for 30 seconds...
    I looked for some answers in the internet and well... The problem seems a little bit more complicated than I originally thought...
    Any help really appreciated!

  3. #3
    Linux Guru Segfault's Avatar
    Join Date
    Jun 2008
    Your hardware is UEFI capable, are you booting in UEFI mode?

    Bootable USB

  4. $spacer_open
  5. #4
    Linux Guru
    Join Date
    Dec 2013
    each of these distros has its own website/wiki etc., with instructions on how to create a bootable usb medium.
    how exactly did you create it? did you follow these nstructions?

  6. #5
    To nihili: The USB-stick works with other machines as I have recently discovered, so it's not it.
    To segfault: UEFI+Legacy right now, thanks to your post I have reviewed some BIOS settings and after slight changes it worked... A little.

    System booted up once to graphical environment. Only once. Then it crushed and it was impossible to boot it up again (don't know why). What's funny - it seems, that it has damaged my main Windows installation. I don't know why too. No tools attached to Windows Rescue Disc worked, system couldn't restore to default settings, it couldn't find any recovery points (I had at least two of them + copy of my files on external drive), I had some wild errors while trying to overwrite MBR. In the end, I gave up. Such things happened to me earlier, but only when I tried installing linux on my hard drive, not trying to boot up from USB-stick. It's insane!

    Thank you for your support, I guess the OS gods have cursed me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts