Find the answer to your Linux question:
Results 1 to 4 of 4
When I run Ethereal network analyser form my live KNoppix CD, it opens but ask root password, when I leave it blank and Click OK, it say wrong password. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    4

    My Knoppix 3.7 need root password when I run Program


    When I run Ethereal network analyser form my live KNoppix CD, it opens but ask root password, when I leave it blank and Click OK, it say wrong password. I did not do any setting in Knoppix 3.7 I just booted my computer with that and start using it. By the way I am posing this messege via Knoppix 3.7 booted CD. Please help me.

    Thanks

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    root password for ethereal

    You have an interesting situation. I don't believe Klaus Knopper has given out the root password for his 3.7 live cd, and the fact that even the "ethereal as root" menu selection asks for a password may be a bug in the distro.

    What I suggest is this : Knoppix Live CD has a "root shell" which is different from the Terminal shell located on the task bar at the bottom of the knoppix 3.7 screen. Look for the Penguin at the lower left of the screen and click on it once. At the bottom of the window which opens you will see a choice for the "root shell"; click on that. A console window will open showing the user as "root@tty1" or something like that. This is the only way I know to access the live cd programs as root.

    Once you are in the root shell, simply type ethereal and press enter. Ethereal should start from the console. Hope this helps.

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    16
    Type su in the terminal will get you root access. You can then run ethereal from there.

    Enoch

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    Knoppix Root Password

    Q: What is the root password?

    A:

    Live CD:

    From the Using FAQ : there is none; in Knoppix LiveCD all passwords are locked by default.

    You can set root password by going Knoppix Menu->Root Shell and typing "passwd", then enterting a root password, also there are several sections you can read dealing with this subject in KNOPPIX/README_Security.txt. You can also type "sudo su" or "sudo -s" in any console window, or use <ctr>-<alt>-F2 to get at the text console with already opened root shell.

    Apparently, however, in some versions of Knoppix, if you type 'sudo -s', it will ask for a password. If you simply press return without entering anything, it will tell you 'Authentication Failed."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •