Find the answer to your Linux question:
Results 1 to 4 of 4
I am having the exact problem as mentioned in Topic http://www.linuxforums.org/forum/top...lwaiting+modem I posted there, but so far no replies. The person there who started the post got it working, but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5

    ActionTec Internal PCI Call Waiting Modem - PROBLEM!


    I am having the exact problem as mentioned in Topic http://www.linuxforums.org/forum/top...lwaiting+modem

    I posted there, but so far no replies.

    The person there who started the post got it working, but ALAS, did not tell the forum what he did to get it working.

    See the other page mentioned above to see what I've done please and what was suggested by Dapper Dan.

    One thing that I've done since my last using Linux is that I used the firmware flash to v.90 for the modem. I'll bet this is why it doesn't get picked up, but I'm not so sure.

    Best Wishes,

    David Ring
    Green Harbor, MA

  2. #2
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    Actiontec Internal PCI Call Waiting Modem and kernel 2.6

    The problem is (mostly) in the 2.6 kernel configuration. You can easily recognize the distributions that will support this modem by doing

    dmesg | grep ttyS

    If you can see ttyS14 there, you have a chance. If not, then you need to recompile the kernel. From the distributions I tried Suse 9.1 and Kubuntu 5.04 do it right. Knoppix 3.4, 3.6 and 3.7, Mepis 3.3.1 test1 and Kanotix do not.

    I managed to get the modem working on Knoppix 3.4 by compiling kernel 2.6.11 and enabling support for more than 4 serial ports there.
    However, the same kernel didn't get the modem to work on Kanotix, so I guess this is not always the full solution.

    I think it is rather stupid not to enable support for more than 4 serial ports. It saves at most several hundred bytes of memory, but leaves the internal modem owners without support for their hardware.

    This problem is not present with 2.4 kernels. The modem is assigned /dev/ttyS4 there.

    Slawek

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5

    Thanks

    The modem uses COM 3 in Windows. I guess you're saying that the kernal assigns high COM port numbers to internal modems like the ActionTec CallWaiting PCI modem.

    Now I have to find out how to recompile - what a treat!

    Any pointers for the knowledge disabled?

    Best Wishes -and a tip of the party hat to you.

    David

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2

    kernel compilation

    >Any pointers

    There may be some Knoppix - specific procedure somewhere. I didn't find any for 2.6.x kernel the last time I looked. Knoppix may be using some patches to modify the kernel.org kernel.

    I followed the procedure in

    http://69.170.105.247:8080/howtos/De..._building.html

    A couple of suggestions in addition to what you can find there:

    1. After unzipping the kernel sources, copy your kernel configuration (this is the /boot/config-2.6.10 file or similar) to the linux-2.6.11.8 directory you have just created and rename it ".config" .
    2. do "make xconfig" instead of "make menuconfig", this is the GUI version that I think is easier to navigate.
    3. I modified the following kernel parameters in device Drivers/Character Devices/ Serial Drivers:

    Unchecked 8250/16559 discovery via ACPI namespace (I am not sure if this is relevant. The Linux ACPI does not work well on my machine).

    set maximum number of nonlegacy 8250/16550 ports to 16

    checked extended 8250/16550 serial driver options

    checked support for more than 4 legacy ports

    checked support for sharing serial interrupts.

    4. After installing your kernel with
    dpkg -i *.deb
    go to /boot directory and do

    mkinitrd -o initrd.img-2.6.11.8 2.6.11.8

    This step is missing from the instructions (I was surprised, but dpkg did not do it for me).

    4. Then go to your /boot/grub directory and add your kernel to the list of the kernels you can boot (edit grub.lst if I remember well), just copy some other entry changing the names to point to your new kernel and initrd.img-2.6.11.8.
    With LILO you need to edit /etc/lilo.conf and run lilo to update Master Boot Record.

    Reboot while praying.
    It never works the first time.

    To be honest I think if you just want to get this modem to work, it is not worth to do all that stuff. Just switch to Kubuntu. Unless you are annoyed by the fact that you don't know how to do something (like me).

    I wish you luck

    Slawek

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •