distro: knoppix remaster 'feather' (hd install)
kernel 2.4.27
arch i386

Apt-get works for me for most packages, but a few random (and important!) packages are giving me some errors I don't understand. Module-init-tools, for example.

When I try to apt-get or dpkg the .deb I get the following dependency error:

Depends: sysv-rc but it's not going to be installed.

I am then prompted to try apt-get -f install, which gives the following error:

Unpacking sysv-rc (from .../sysv-rc_2.86.ds1-1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/sysv-rc_2.86.ds1-1_all.deb (--unpack):
trying to overwrite `/etc/init.d/rc', which is also in package sysvinit
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/sysv-rc_2.86.ds1-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any help would be greatly appreciated.