Find the answer to your Linux question:
Results 1 to 7 of 7
Hello, I've installed various versions of knoppix to hard drive, but never encountered this problem. CDROMs are recognized and are mounted without problems when running knoppix from the CD, but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5

    cdrom not mounting on knoppix 3.8.1 hd install


    Hello,

    I've installed various versions of knoppix to hard drive, but never encountered this problem. CDROMs are recognized and are mounted without problems when running knoppix from the CD, but on my hd install with this particular version (that uses kernel 2.6.11):

    Code:
    # mount /cdrom
    mount: /dev/cdrom is not a valid block device
    Same thing for my slave CDROM drive. I believe the relevant fstab lines are fine (they worked for me in the past):

    Code:
    # cat /etc/fstab | grep cdrom
    /dev/cdrom /cdrom  iso9660  defaults,ro,user,noexec,noauto  0  0
    /dev/cdrom1 /cdrom1  iso9660  defaults,ro,user,noexec,noauto  0  0
    So I checked dmesg, and what's on /dev/cdrom and /dev/cdrom1 (I have two CDROM drives):

    Code:
    # dmesg | grep CD
    hdc: HL-DT-ST RW/DVD GCC-4481B, ATAPI CD/DVD-ROM drive
    hdd: HL-DT-ST DVDRAM GSA-4120B, ATAPI CD/DVD-ROM drive
    # ls -l /dev/cdrom /dev/cdrom1
    lrwxrwxrwx  1 root root 8 Apr 17 14:13 /dev/cdrom -> /dev/hdc
    lrwxrwxrwx  1 root root 8 Apr 17 14:13 /dev/cdrom1 -> /dev/hdd
    At this point I don't know what to do to get the CDROMs working, and some help would be most appreciated!

    Thanks in advance.

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    May I ask what are you trying to mount? Is this a normal cd?
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5
    Quote Originally Posted by serz
    May I ask what are you trying to mount? Is this a normal cd?
    I tried mounting both data and music cds; it didn't make any difference.

  4. #4
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    Well, you don't have/need to mount audio-cds, data cds should work just fine..

    Are you using a kernel you compiled yourserlf?
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  5. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5
    Quote Originally Posted by serz
    Well, you don't have/need to mount audio-cds, data cds should work just fine..
    You're right, I just wanted to see if I could mount them and read its contents. In short, the problem doesn't seem to be related to the type of CD; somebody asked me to check whether it's possible to communicate with the drive. So I did

    Code:
    # eject /dev/cdrom1
    eject: unable to open `/dev/hdd'
    Are you using a kernel you compiled yourserlf?
    No, it's the 2.6.11 that knoppix 3.8.1 comes with, which I installed with knoppix-installer, and choosing the "debian-like" installation option.

  6. #6
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    How are the permissions of /dev/hdc and /dev/hdd set?
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  7. #7
    Just Joined!
    Join Date
    Jul 2005
    Posts
    1

    Re: cdrom not mounting on knoppix 3.8.1 hd install

    Quote Originally Posted by patitoconejita
    Hello,

    I've installed various versions of knoppix to hard drive, but never encountered this problem. CDROMs are recognized and are mounted without problems when running knoppix from the CD, but on my hd install with this particular version (that uses kernel 2.6.11):
    I am having exactly the same problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •