Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, i'm using Knoppix 3.7 live cd everything work fine except the internet. I tryed to configure (knoppix menu-->Internet/Network->Network Card Configuration) my eth0 network card which is a Marvell Gigabit ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    Internet not working... need help


    Hi,

    i'm using Knoppix 3.7 live cd everything work fine except the internet.

    I tryed to configure (knoppix menu-->Internet/Network->Network Card Configuration) my eth0 network card which is a Marvell Gigabit 1gbps or VMWare Vitual Network Card when i run Knoppix through VMWare.

    My networks settings are :
    192.168.1.100 for the Gigabit
    192.168.10.100 for the virtual network card.
    255.255.255.0 subnet mask
    192.168.1.1 is the router d-link BEFSR41 (gateway,dns)
    and im running on the dmz and the DHCP server is off (because ip where changing once in a week)

    Both on vmware or when booting with knoppix , the internet dont work and when i enter these settings in the network card configurator, eth0 still dont work .

    I Entered these settings
    DHCP Broadcast: No (Tryed Yes but failed)
    eth0 Network Card IP:192.168.1.100
    Subnet mask: 255.255.255.0
    Broadcast Adress IP : 192.168.1.1 (dunno what it is , maybe its for DHCP but im not using it ,, ip are set manualy and not automaticaly from the router)
    Default Gateway: 192.168.1.1
    NameServer:192.168.1.1 (??? DNS ??? )

    Result: ERROR:NETWORK UNREACHABLE

    Could you please help me to setup my internet because i never did that before (both mandrake 10 and redhat 9 , i never had to configure my internet connection)?

    Also, what is Nameserver and DHCP Broadcasting because the network card configuratior ask for that?

    Sorry for my english

    Thank you,
    ELCouz

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    You have to add your ISP's DNS this way:

    Edit /etc/resolv.conf, it should look like this:
    nameserver 192.168.1.1
    That should work, if it doesn't, add your ISP's DNS.
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •