Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, Just added knoppix 3.8 to my HD, but have lost using flash drives on my usb. All else works great, sound , video...etc. I haven't done any upgrades ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! codeconfused's Avatar
    Join Date
    Apr 2005
    Location
    Ct,USA
    Posts
    26

    3.81 on HD no usb detect


    Hi all,
    Just added knoppix 3.8 to my HD, but have lost using flash drives on my usb. All else works great, sound , video...etc. I haven't done any upgrades because it works so great. Any idea's on how to get auto mount working for my flash drives? I tried hotplug, but no luck If I have to do some upgrades I will. This time I'm only going to add stable not testing programs.

  2. #2
    Just Joined! codeconfused's Avatar
    Join Date
    Apr 2005
    Location
    Ct,USA
    Posts
    26

    usb printer fine

    My lilo output my hold some answers.

    /proc/misc: No entry for device-mapper found
    Is device-mapper driver missing from kernel?
    /dev/mapper/control: open failed: No such device
    Failure to communicate with kernel device-mapper driver.
    /proc/misc: No entry for device-mapper found
    Is device-mapper driver missing from kernel?
    /dev/mapper/control: open failed: No such device
    Failure to communicate with kernel device-mapper driver.
    Incompatible libdevmapper 1.00.20-ioctl (2005-01-06)(compat) and kernel driver
    Added Linux
    Added Linux(2.6)-1 *

    My usb printer is working fine? It seems that they changed how usb works. Even if auto mount didn't work, I could always go in via prompt, but fdisk-l never shows the usb flash drive. It should be /dev/sda1, 2 so on... both kernals don't auto detect.

  3. #3
    Just Joined! codeconfused's Avatar
    Join Date
    Apr 2005
    Location
    Ct,USA
    Posts
    26

    usb working solution

    I got flash drives and floppies to mount. The usb has been changed in 3.8 Now the flash drive is mounted as uba1 instead of sda1 I got it to work by doing "apt-get update" then "apt-get upgrade" Then I added some programs I wanted. example "apt-get install kvirc" Then last, but not least I did "apt-get dist-upgrade". After that it picked it up no problem...and has a better icon for flash drives instead of the hard drive icon that it was before.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •