Find the answer to your Linux question:
Results 1 to 5 of 5
Once that I installed Knoppix to my hard drive, it would no longer connect to the internet, nor would it let me log on to KDE, due to lack of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Location
    SE United States
    Posts
    20

    Installed K no etho


    Once that I installed Knoppix to my hard drive, it would no longer connect to the internet, nor would it let me log on to KDE, due to lack of internet connection.

    I can make it work by using the command line;

    /sbin/ifconfig lo down
    /sbin/ifconfig eth0 down
    /sbin/ifconfig lo 127.0.0.3
    /sbin/ifconfig eth0 192.168.3.100 broadcast 192.168.1.255 netmask 255.255.255.0
    /sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo
    /sbin/route add -net 192.168.3.0 netmask 255.255.255.0 eth0
    /sbin/route add default gw 192.168.3.254 eth0
    hostname localhost.localdomain

    Then I can log into KDE and by using netcardconfig, log on to the internet. The problem is that I have to do this each and every time that I reboot! There has to be a better way and I am hoping that someone can point me to it.

    Thanks, zoey

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    http://www.plope.com/Members/chrism/...rc_local_equiv

    You just need to add all those commands to the /etc/init.d/local file.
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Location
    SE United States
    Posts
    20
    Thanks. I should have said that I am running Kanotix/Knoppix and it has /etc/init.d, but no /etc/init.d/local, or am I just not understanding the correct way to type it in? That is certainly a possibility.

    zoey

  4. #4
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    /etc/init.d is a directory which has all the initscripts that could be used. /etc/init.d/local is a file, you should have it.

    Knoppix is based on Debian, that's why.
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  5. #5
    Just Joined!
    Join Date
    Sep 2004
    Location
    SE United States
    Posts
    20
    I found /etc/network/interfaces, which looks like the file that I want, at least it starts out;

    iface lo inet loopback

    and that is how the debian file is described in rute.
    I added all the information and also went to the /etc/network/options file and changed ip_forward=no to ip_forward=yes, but I still can't log on to kde without re-entering all of the imformation from my first post.

    There has got to be a way to do this and I would appreciate some more suggestions to help me find it!

    Thanks, zoey

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •