Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005

    Knoppix can not access my harddrive!

    Hey. I'm new to knoppix, got it a week ago. I've got a few problems though.

    first, I can't access my harddrives. when i click ''Hard Disk (sda) /mnt/sda/", a box shows up:

    "/dev/sda: Input/output error

    mount: I could not determine the filesystem type, and none was specified

    Please check that the disk is entered correctly."

    Edit: These are SATA Drives. I am no hardware freak, so i haven't got knowledge about what SATA is, But could that be the problem?

    Of course, It is entered correctly, since i also use windows. could this be the problem? I've read on the web about knoppix being able to read almost all disks. I think the filesystem is FAT32, if that could be the problem. also, i can click "Hard disk (sys) /sys/" but i get another box with the text:

    "mount: only root can mount /sys on /sys

    please check that the disk is entered correctly"

    My other problem, (probably depending on this one) is that i can't save knoppix configuration. I've done it on a floppy disk, but when i type "knoppix myconfig=/mnt/auto/floppy", it makes an attempt to load the config, but it doesn't find the dir. and "knoppix myconfig=scan" doesn't work either, it won't find anything.

    And, this is not necessary, But i'd like to have sound enabled... is it possible with a live-cd?

    if you come up with an answer to these problems, please keep in mind that i cannot download any bigger files, since I'm using a 56k.

    Please help a learning Newbie.

    Thanks, GuessWho.

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Noplace Interesting
    Fat32 drives are NOT the problem. It's the NTFS filesystems that knoppix has trouble writing to them.

    I get that error sometimes when I try & mount a crazy floppy disk sometimes.
    You can get it to work by doing this (as root)
    mount -o umask=000 -t vfat /dev/sda1 /mnt/sda1
    *note* you will only be able to access this drive as root unless you do this:
    mount -o users,exec,umask=000,uid=<your_user_id>,gid=<your_ group_id>

    /dev/sda refers to the WHOLE disk instead of a perticular partition.
    /dev/sda1 refers to the 1st partition in the master boot record.

    These commands may seem a little cryptic, but if you have something like the following somewhere in /etc/fstab
    /dev/sda1 /mnt/sda1 vfat noauto,users,exec,rw,umask=000,uid=<your_user_id>, gid=<your_group_id>

    then all you should have to type is
    mount /dev/sda1

    Yeah, I have dialup too, and it sucks. I've offered to pay for a DSL bill, but my parents think all technology is evil, so they won't let me.

    Oh, yeah, if you wanna see if sound works, try playing a .mp3 or .wav file or something by using xmms (type xmms at a terminal).

    Plus try this for boot options:
    knoppix myconfig=/dev/fd0
    /dev/fd0 referrs to the whole floppy disk, oddly enough
    you can't reach /mnt/auto/floppy because it is not mounted yet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts