Find the answer to your Linux question:
Results 1 to 5 of 5
I just got a new modem that says it will work with linux. Come to find out, one the readme, it says that it is compatible with redhat and a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    26

    Modem w/ linux drivers


    I just got a new modem that says it will work with linux. Come to find out, one the readme, it says that it is compatible with redhat and a couple other distros. it says nothing about knoppix, and im not sure if it will work with knoppix.

    It is a 56k, V.92, with a motorolla chipset. I'm not sure where to put the drivers so that it will work. I tried using Vdialer by typing it in root shell. It came up in root, and there weren't too many options when i typed vdialer --help. I would think there would be more

    It worked fine on windows. In fact, it said that it was connecting at 115k! My other modem connects @ 50k. I thought that the FCC limited connection speeds to 53k/s at the most. Strange huh?

    Thanks

  2. #2
    Linux User twoHats's Avatar
    Join Date
    Jan 2005
    Location
    NH, USA
    Posts
    280

    Re: Modem w/ linux drivers

    Well ...

    Usually if a modem works with Linux it works - assuming you are not using a really old Linux. The distinction seems to be whether you have a winmodem or not - if the box says it works with Linux then it's probably *not* a winmodem.

    Try KPPP in KDE and see if you can set your modem up there.

    Is it internal or external?

    The speed thing is the baud rate from the computer to the modem - not from the modem to the world. The thing to watch is KB/S when doing a download multiply by 10 (rough) to get Kb/s - so if you see 6.7 KB/s you are at around 67kbs which is done by compression etc on a 56K modem.

    btw the speed is not regulated by a government agency, but rather by the physical configuration of twisted pair phone lines.

    Have fun
    - Clouds don't crash - Bertrand Meyer

    registered Linux user 393557

    finally - hw to brag about - but next year it will look pitifully quaint:
    Athlon64 X2 3800 - 1G PC3200 - 250G SATA - ati radeon x300
    circa 2006

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    26
    The modem is internal, and very small (therefore very new). It is a software modem, not hardware unfortunately. Do I HAVE to have the drivers installed, or will it work without the drivers (assuming my computer can find it)

    I tried KPPP without success.

    I really want to try and use wvdial, cuz everyone says it is much better than KPPP. I get this error message when I try it though:
    Wdial: Error while loading shared libraries: libstdc++-lib6.1-1.so.z: Cannot open shared object file: No such file or directory

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    That's a missing link (or dependency). As root, do an 'updatedb' and afterwards 'find libstdc++' on your system to see if any similar files are found. If there are, and they are more recent than the version that is needed, make a symlink to it with the name of the missing file, and the problem should be solved
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  6. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    26
    I did what you said borromini, and it worked. Only problem is I'm getting this error now:
    -->Can't read config file /etc/wvdial.conf: No such file or directory
    -->Wvdial: Internet dialer ver 1.41
    -->Warning: Section [dialer defaults] doesn't exist in wvdial.conf
    -->cannot open /dev/modem: Is a directory
    I ran the command: wvdialconf wvdial.conf, and it seemed to work, with the acception that it couldn't get my modem working right. It is looking in /dev/modem for my modem drivers, but cannot find them because they're not there.

    I have the drivers on a CD, in rpm form. I am using alien to install them, and it works very smoothly. The only problem is that I cannot specify that I want them to install in /dev/modem. How in the world do I do this? I'm rather quite stumped.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •