Find the answer to your Linux question:
Results 1 to 7 of 7
how to correctly remove programs from knoppix (version 3.4)?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie DeoXMAN's Avatar
    Join Date
    Jul 2005
    Location
    Azerbaijan, Germany
    Posts
    154

    Removing programs from Knoppix


    how to correctly remove programs from knoppix (version 3.4)?

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Code:
    apt-get remove program

  3. #3
    Linux Newbie DeoXMAN's Avatar
    Join Date
    Jul 2005
    Location
    Azerbaijan, Germany
    Posts
    154
    here is the what i get writing
    Code:
    apt-get remove xtel
    Code:
    Reading Package Lists... Done
    Building Dependency Tree... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      libatk1.0-dev: Depends: libatk1.0-0 (= 1.10.1-2) but 1.4.1-1 is to be installed
      libc6-dev: Depends: libc6 (= 2.3.2.ds1-12) but 2.3.2.ds1-22 is to be installed
      libglib2.0-data: Depends: libglib2.0-0 (= 2.2.3-1) but 2.6.4-1 is to be installed
      libgtk2.0-dev: Depends: libgtk2.0-0 (= 2.6.4-3) but 2.2.4-6 is to be installed
      locales: Depends: glibc-2.3.2.ds1-12 but it is not installable
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    what is that? why i need any dependency, when i want to REMOVE program.....

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    It means there are broken packages. Just run:
    Code:
    apt-get install -f
    to fix it.

  6. #5
    Linux Newbie DeoXMAN's Avatar
    Join Date
    Jul 2005
    Location
    Azerbaijan, Germany
    Posts
    154
    and what about
    Code:
    ./configure
    make 
    make install
    ?
    do you use apt-get install program?

  7. #6
    Linux Newbie DeoXMAN's Avatar
    Join Date
    Jul 2005
    Location
    Azerbaijan, Germany
    Posts
    154
    Code:
    root@box:~# apt-get install -f
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Correcting dependencies... failed.
    The following packages have unmet dependencies:
      libatk1.0-dev: Depends: libatk1.0-0 (= 1.10.1-2) but 1.4.1-1 is installed
      libc6-dev: Depends: libc6 (= 2.3.2.ds1-12) but 2.3.2.ds1-22 is installed
      libglib2.0-data: Depends: libglib2.0-0 (= 2.2.3-1) but 2.6.4-1 is installed
      libgtk2.0-dev: Depends: libgtk2.0-0 (= 2.6.4-3) but 2.2.4-6 is installed
      locales: Depends: glibc-2.3.2.ds1-12 but it is not installable
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies

    what i have done wrong?

  8. #7
    Linux Newbie DeoXMAN's Avatar
    Join Date
    Jul 2005
    Location
    Azerbaijan, Germany
    Posts
    154
    same thing everythime, not depending what i wanna install:
    Code:
    Reading Package Lists... Done
    Building Dependency Tree... Done
    E: Couldn't find package gcal
    WHAT IS THAT??

    do you think that is would be better to change system?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •