Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Guys I'm a newbie like so many others here. I'm just needing to get Knoppix setup so I can start learning linux. Knoppix sets up great on my laptop only ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    7

    Help with thumbdrive?


    Guys I'm a newbie like so many others here. I'm just needing to get Knoppix setup so I can start learning linux. Knoppix sets up great on my laptop only thing is I can't get it to recognize my thumbdrive. I need the thumbdrive to load drivers for my wireless network card. I have tried
    "knoppix myconfig=scan" and this what I get at the end of the boot sequence
    "Checking /mnt/ for KNOPPIX configuration files..."
    "Filesystem not autodetected, trying to mount /dev/ with AES256 encryption"
    "/dev/: is a directory"
    "Mount failed, retry? [Y/n]"
    ok now when I try "knoppix myconfig=/dev/sda1" I get this
    "Checking /mnt/sda1 for KNOPPIX configuration files..."
    "/dev/sda1: No such device or address"
    "Mount failed, retry? [Y/n]"
    Now on the thumbdrive it says usb 2.0, is that a problem also the drive is not formatted with a linux partition. If the latter how do I format the thumbdrive from linux? Any help would be greatly appreciated!

  2. #2
    Linux User Game master pro's Avatar
    Join Date
    Sep 2005
    Location
    Tasmania, australia
    Posts
    274
    try doing

    Code:
    mount /dev/sda1 /mnt/sda1
    not sure if that'll work, but it might

  3. #3
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    You shouldn't have to format the drive with a linux filesistem. Strange, Kanotix (which is built on Knoppix) recognised my usb stick by default, I just plugged it in. Is it maybe encripted? Try what was mentioned above, also try pluging it in before running knoppix. You should see it on your desktop (along with the other partitions on your disk).
    Stumbling around the 'net:
    www.cloudyuseful.com

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    7
    Ok I did "mount /dev/sda1 /mnt/sda1" and I get
    "mount: mount point /mnt/sda1 does not exist"
    Also I failed to mention it is Knoppix STD, don't know if that matters.

  6. #5
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    Quote Originally Posted by Poe4
    Ok I did "mount /dev/sda1 /mnt/sda1" and I get
    "mount: mount point /mnt/sda1 does not exist"
    Also I failed to mention it is Knoppix STD, don't know if that matters.
    You have to make the file where you will mount the thing (in this case, /mnt/sda1). Have you tried booting knoppix with the usb key pluged in? I don't know how different the STD version of Knoppix is, though, it could be that the settings have been changed.
    Stumbling around the 'net:
    www.cloudyuseful.com

  7. #6
    Just Joined!
    Join Date
    Sep 2005
    Posts
    7
    Yes I am booting Knoppix with the thumbdrive in. I'm at the boot prompt, plug the drive in the computer beeps and the light comes on, on the thumbdrive. Then Knoppix boots, and while it is booting it says
    "USB found, managed by hotplug"
    "Enabling hotplug manager"

  8. #7
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    ... but you don't see it on your desktop? Knoppix automounts usb drives, read about it here: http://en.wikibooks.org/wiki/Knowing...rnal_USB_drive
    What's your /etc/fstab say? (do you see a line that starts with /dev/sda1 in it? If yes, what does it read?)
    Stumbling around the 'net:
    www.cloudyuseful.com

  9. #8
    Just Joined!
    Join Date
    Sep 2005
    Posts
    7
    No It isn't on my desktop,the line in /etc/fstab says
    "/dev/sda1 /mnt/sda1 auto noauto,users,exec 0 0"

  10. #9
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    Quote Originally Posted by Poe4
    No It isn't on my desktop,the line in /etc/fstab says
    "/dev/sda1 /mnt/sda1 auto noauto,users,exec 0 0"
    Stupid me, of course it's not on the desktop. I just checked the STD website, and this version of Knoppix uses Fluxbox as the GUI, which usually doesn't have any icons on the desktop (note that normal Knoppix has KDE by default, and all partitions, including usb sticks show up as icons on the desktop). Open up a file browser (find one in the menu, or open a console and type 'mc') and move to /mnt/sda1, you should (hopefully) see the files on the usb stick.

    You want to save your configuration, right? Here's the info on how to do that:
    http://www.knoppix-std.org/doc-crypto_home.html

    edit: another possibility is to change the line in fstab, here's mine:
    /dev/sda1 /mnt/sda1 vfat noauto,users,exec,umask=000 0 0
    Stumbling around the 'net:
    www.cloudyuseful.com

  11. #10
    Just Joined!
    Join Date
    Sep 2005
    Posts
    7
    I switched to Knoppix 3.8 and everything seems to be working fine, thnaks for all your help!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •