Find the answer to your Linux question:
Results 1 to 2 of 2
I hope that you folks will be more helpful that the itrc guys... I wasn't sure where to begin this thread: here or in the Peripheral / Hardware forum. Please ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Location
    Brussels, Belgium
    Posts
    1

    Problem with Knoppix, Win 2003, RAID 5 smartarray on a HP Proliant Server


    I hope that you folks will be more helpful that the itrc guys...

    I wasn't sure where to begin this thread: here or in the Peripheral / Hardware forum. Please moderators move this thread as best suited.

    Copied from the itrc forums (storage / smartarrays)

    This isn't dramatic as it is happening on a test server but I can't put the finger on the problem.

    The setup: ML350 w/ 2GB RAM, Smartarray 641 RAID5 3x72,8GB, Windows 2003 server Std Ed.

    The array is configured as a single logical disk divided in 1 4GB boot partition, 2 primary partitions and 1 extended partition holding 1 logical drive.

    I want to expand the array with 2 additional disk, increase the logical disk size and finally all the partitions sizes (with the exception of the 4GB boot partition holding the OS).

    I'm using the following method (which works fine when I'm replacing IDE HDDs with bigger ones in workstations):

    -start the server with a Knoppix Live-On Linux CD
    -create the cciss device
    -copy the whole logical drive as an image file on another HDD (bit-to-bit with dd, over the network with netcat as the IDE controller of the ML350 doesn't support DMA)
    -mount the partitions from the image file and open a few files at random to test the copy -> OK
    -shut down the server, install the 2 extra HDDs, delete the logical disk and create a bigger one from the ROM.

    From now on, I've tried those two variants with the same (lack of) results:

    A)
    -start with Knoppix again and create the cciss device
    -using fdisk, create empty partitions at the new (increased) size

    B)
    -make a blank install of Windows 2003 server
    -using the disk manager, create empty partitions at the new (increased) size

    Then the last steps:

    -using dd and netcat, copy each partition one by one from the image file into the new partitions on the server
    -mount each partition and open files at random to test the copy -> ok
    -remove the Knoppix CD and restart the server

    During boot, the server hangs at "Attempting to boot from C:"

    If I use the recovery console from the Windows 2003 server CD, I can access the files on the boot partition. Using FIXMBR and FIXBOOT hasn't helped.

    I've tried a lot of ways to try and fix this. Instead of the "Attempting..." message, I've sometimes received a "A read error has occurred, Press Ctl-Alt-Del now" but I can't remember what I had done at this time.

    However, if I remove 2 HDDs from the array and recreate the logical disk at its original size, the server will start all right after restoring image file as a whole.

    I've also tried to install a GRUB to 'jumpstart' Win 2003. I need to read the GRUB manual pages further because I think that my setup was faulty. However, I've noticed this: when linux is loaded and the cciss device is created, the geometry of the logical drive is 255 heads, 63 sectors and 35419 cylinders. The geometry stays the same with a 3 or 5 HDDs RAID array, only the size of the cylinders change. During boot, invoking the geometry command of grub shows 255H, 63S, 1024C.

    I suspect a geometry problem in the first stage of the boot. Could it come from the boot sector from the boot partition?

    I could do with any pointer. Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    Problem with Knoppix, Win 2003, RAID 5 smartarray on a HP Proliant Server

    Go to the HP site
    Download the Smart Start CD
    Boot to it and go to the ACU (Array configuration utility)
    This application has a function to expand the array, just be careful to choose the correct RAID level and logical drive options

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •