I am trying to get a pcmcia modem up and running in Knoppix based Damn Small Linux (DSL) and have been unable to get the modem to connect when I use pppd. There seems to be some descrepencies in terms of how the modem is listed in /dev as compared to how it is listed in other [working]
distros. I know the modem uses a couple of internal 16550A UARTs
however in DSL it comes up as two UARTs (ttyS00 and ttyS01) and in
Ubuntu it comes up as one (ttyS0). Ubuntu also automatically links
/dev/modem to ttyS0. In DSL I have attempted to do so to both ttyS00
and ttyS01 on two seperate attempts with no success. I wish I could
provide more detailed error information, however all I get is a
"Connect script failed" error in pppd.

Any ideas on this one are greatly appreciated. Please review the
information below, thanks:

=== Output of pppd in Damn Small Linux (DSL)[Not Working] ===
dsl@box:~$ sudo pppd nodetach call mymodem
Connect script failed
================================================
(this output occurs when I've tried symbolically linking /dev/modem to
/dev/ttyS0, /dev/ttyS00 and /dev/ttyS01)


=== Output of dmesg in Damn Small Linyx (DSL)[Not Working] ===
dsl@box:~$ dmesg
...
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
...
=================================================

=== Output of dmesg in Ubuntu [Working] ===
...
[4294669.799000] Serial: 8250/16550 driver $Revision: 1.90 $54
ports, IRQ
sharing enabled
...
[4295038.910000] ttyS0 at I/O 0x3f8 (irq = 5) is a 16550A
...
===================================
=== /dev/modem in Ubuntu [Working] ===
/dev/modem is symbolicly linked to '/dev/ttyS0'