Find the answer to your Linux question:
Results 1 to 2 of 2
Sorry for the double post... I posted a similar question under linux newbies, and then found this thread on Knoppix and thought I would most likely get more specific advice ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    8

    hfsplus in knoppix 5.x?


    Sorry for the double post... I posted a similar question under linux newbies, and then found this thread on Knoppix and thought I would most likely get more specific advice to my problem.

    I have read on other websites that the kernel included with Knoppix 5.x has HFS support included, but that it needs to be configured through xconfig. I cannot load xconfig to see if that is the case or not.

    From the terminal I have tried:

    knoppix@1[knoppix]$ cd /usr/src/linux
    knoppix@1[linux]$ make xconfig

    and get these errors:

    Makefile:266: /UNIONFS/usr/src/linux-2.6.17/scripts/Kbuild.include: No such file or directory
    Makefile:403: /UNIONFS/usr/src/linux-2.6.17/arch/i386/Makefile: No such file or directory
    make: *** No rule to make target `/UNIONFS/usr/src/linux-2.6.17/arch/i386/Makefile'. Stop.

    I am brand new to linux, so I am guessing there is something basic I am missing here? Does anyone know if the included kernel will enable support for HFS, and if so, what am I doing wrong trying to access xconfig.

    This is the website I have been looking at: http://gentoo-wiki.com/HOWTO_hfsplus . If the kernel does not support HFS as is hinted at in this site, can anyone walk me through installing the files listed on this site to add it? I have tried following the steps the author has listed on the site for Gentoo, but have had no success in that either.....

    Please keep in mind I am brand new to linux, so a little hand holding may be required, but I catch on pretty fast.

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    8
    ok I have done some more research (and probably gotten myself in even deeper over my head)

    I found the hfs and hfsplus files in a /lib/.../kernel/fs/ subdirectory. There is a file contained in each hfs.ko or hfsplus.ko (this getting my any warmer ?)

    I also ran:
    modprobe hfs
    modprobe hfsplus

    no errors were returned, does this mean it loaded the modules?

    if I type:

    cat /proc/filesystems | grep hfs

    it returns

    hfs
    hfsplus

    Does this mean linux is configured to recognize the file system? (when I use fdisk or parted on my ipod drive it still only shows 2 partitions the first being "empty" )

    I have no idea if I am getting anywhere or not.... someone let me know if I am even in the right ballpark?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •