Find the answer to your Linux question:
Results 1 to 3 of 3
I've just started using Knoppix, and am working through the "Knowing Knoppix| beginners guide. I've worked out how to mount the USB drive and save to it, but when I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    1

    Unable to unmount USB key


    I've just started using Knoppix, and am working through the "Knowing Knoppix| beginners guide. I've worked out how to mount the USB drive and save to it, but when I try to unmount it, I get the message "Device is busy". I've tried typing umount /media/sda1 into the root shell but get the same response.

    Any idea what the problem is?

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    I don't know the cause, but I've seen this problem on USB flash drives as well as local hard drives. One way to get around it is to pass the -l flag to umount, like so:
    Code:
    # umount -l /media/sda1
    That will release the mountpoint. Be careful with this one, though, because if the device really is still busy, it will continue to finish up any operations it was doing even after you unmount it. So it's possible to yank the USB key before it's done, and it won't complain (since it was unmounted). Because of this, don't pull it out until you're confident it really is done being accessed.
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    68
    Try right clicking the desktop icon, and in the menu that pops up, you should have an option to unmount.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •