Find the answer to your Linux question:
Results 1 to 10 of 10
I am running a Dell Dimension 9100 with an integrated audio card and I cannot get sound. I tried alsaconf with each of the selections, none work. I have tried ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    4

    Question Audio Card Problems


    I am running a Dell Dimension 9100 with an integrated audio card and I cannot get sound. I tried alsaconf with each of the selections, none work. I have tried the Soundcard Configuration program, and it gives me the following message.

    ERROR: No Sound Modules found
    You don't seem to be running a kernel with modular sound enabled. (soundcore.o was not found in the module search path). To use sndconfig, you must be running a kernel with modular sound, such as the kernel shipped with Debian GNU/Linux or a 2.2 kernel, and sound must be compiled as modules.

    What do you suggest I do?

    Thanks

  2. #2
    Linux Newbie objuan's Avatar
    Join Date
    Jul 2006
    Location
    california
    Posts
    234
    try adding snd and soundcore to the /etc/modules file

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    4

    Audio Card Problems

    How would I do that? (I am new to linux)

  4. #4
    Linux Newbie objuan's Avatar
    Join Date
    Jul 2006
    Location
    california
    Posts
    234
    edit the /etc/module file and type in at the bottom of the list
    snd
    soundcore
    save the file and restart your system

  5. #5
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Try "modprobe snd" before
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  6. #6
    Just Joined!
    Join Date
    May 2005
    Posts
    48
    I assume you have Knoppix 5.0.1
    try on the konsole
    lspci
    and
    lsmod
    lspci maybe will tell what audio driver it is.
    lsmod tells if it's installed correctly in the modular kernel.
    usually alsaconf in root should work (don't choose legacy)
    if btw it's digital alsamixer should have a anlog/digital switch(off). use m to turn it on.
    usually it's difficult to establish sound because alsa can't make a driver for every sound card.

  7. #7
    Just Joined!
    Join Date
    Sep 2006
    Posts
    4
    I tried the first 2 methods and no success.

    This is what came up when I did the lspci for audio.
    0000:00:1b.0 0403: Intel Corporation 82801G (ICH7 Family) High Definition Audio
    Controller (rev 01)
    I am not sure what I do with the audio card for the lsmod...so it is still not working.

  8. #8
    Just Joined!
    Join Date
    May 2005
    Posts
    48

    soundcard

    try in su root
    root[ ]$ alsaconf
    and choose hda-intel instead of legacy. This is the driver you require.
    check with
    ]$ lspci
    if it's installed
    also kmix icon on the gui below should be working.
    if it's digital use
    ]$ alsamixer
    and turn on analog/digital ouput jack
    then
    ]$ alsactl store
    to save.
    if you need to turn off pnp then at boot use cheatcode
    knoppix nopnp
    reference for alsa is here

  9. #9
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1

    alsaconf worked for me

    Hey everyone. Just wanted to say thanks waka, alsaconf worked great for me..took about a minute. I am running knoppix 5.0.1 installed on the HD...worked nicely. Thanks everyone. I now have sound.

    JM Brown
    www.fret-master.com

  10. #10
    Just Joined!
    Join Date
    Sep 2006
    Posts
    4
    Hey Guys,

    I got it working...turns out I was an idiot and in KMix Surround was turned off and once I turned it on, BAM sound works! Thanks so much for all you help!

    ~Juddster

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •