Find the answer to your Linux question:
Results 1 to 4 of 4
I've gotten into Knoppix and like it so much I wanted to add a second CD drive to my Gateway E-4400. So I did. And now Knoppix won't boot from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    4

    Question Added CD; won't boot


    I've gotten into Knoppix and like it so much I wanted to add a second CD
    drive to my Gateway E-4400. So I did.
    And now Knoppix won't boot from the CD drive anymore.
    Both drives show up fine in Windows but when I try to boot
    Knoppix it just goes ahead and boots from the hard drive. I can
    disconnect either CD drive and Knoppix boots fine from the remaining one.
    Any suggestions?

  2. #2
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    Sounds like a BIOS problem, your motherboard may not know which drive to boot from if they are both connected. Are they both on the same IDE channel? Check out if you can set the boot order in the BIOS when both are connected.

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    68
    Also make sure one drives jumpers are set as slave, and one as master. If theyre both set as master, it will give you problems booting from them.

  4. #4
    Just Joined!
    Join Date
    Sep 2006
    Posts
    4

    Thumbs up Got it to work

    It's now booting. Not real sure how. Knew it had to be a combination of BIOS settings and jumpers. Worked on it most of the afternoon and finally got it. Crazy thing is, it's only booting on one CD drive which is older than some of the others I tried.

    Guess this wasn't really a Linux-specific question. Sorry. Thanks for the comments.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •