Hi,

I'm new to Linux. I started using it at Uni (studying Comp-Sci), but their Linux is teh_ugly and really really slow and I always make the Gnome desktop crash... So I decided to see if that was just the schools build or generally that way. So I chose Knoppix because I don't need to install anything. I can say Knoppix is running faster on my laptop, but not by much... that's either because it runs from CD or because I have a Toshiba laptop, and Toshiba sucks.
I went with Knoppix because I have previously used it as a restore Windows help, when some kind of weird failure occurs. Now I use full copies of HDDs so it's not required anymore.
Now to my real problem. My laptop has one wireless card, one ethernet, and one dial up modem. I want to set the wireless to Master and got an error in the terminal:
Code:
iwconfig wlan0 mode Master
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Operation not permitted.
So first I thought, damn it, my wireless card doesn't support this... but then I got thinking, not wanting to give up, so I set the root password and went root to try it again.
Code:
iwconfig wlan0 mode Master
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; No such device.
Guess I just figured I should try root and it tells me that I have no such device. So I'm like what? So I tried the next command that I thought could result in something.
Code:
iwconfig
lo        no wireless extensions.

eth0      IEEE 802.11b  ESSID:""  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.442 GHz  Access Point: 00:03:52:EA:D6:90
          Bit Rate:11 Mb/s   Sensitivity:1/3
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/92  Signal level=-83 dBm  Noise level=-121 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth1      no wireless extensions.

sit0      no wireless extensions.
Now as I understand lo is the local routing, and eth1 is the connection I am using the internet through (checked via Ethereal). Now as far as I can tell eth0 should be wlan0, but isn't for some reason. Did I break something? How can I make this into wlan? I mean it's obvious that it is but obviously not recognised for some reason. Now I tried setting eth0 to Master, but I figured it should fail, but since I don't know Linux all to well, maybe it failed because my WiFi card doesn't support it.
Code:
iwconfig eth0 mode Master
Error for wireless request "Set Mode" (8B06) :
    SET failed on device eth0 ; Operation not supported.
BTW what is "sit0"? And how can I simply lookup info about these connections?

P.S. For some reason I am enjoying Linux, probably because it's all new and shiny.