Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I am new to Knoppix; am using it to recover data from a hard drive that cannot be accessed via Windows (inpage operation error). I have booted with Knoppix 5.01. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    2

    unable to copy files from hd to hd


    I am new to Knoppix; am using it to recover data from a hard drive that cannot be accessed via Windows (inpage operation error). I have booted with Knoppix 5.01. Internal drives are recognized as hda and hdb; bad drive is attached via external USB and is recognized as sda. I am able to see the folder that I want to recover, but when I try to copy it from sda to either hda or hdb, I get an error message indicating that I do not have proper permissions. As far as I know, I have both read and write permissions for both hda and hdb. Can someone advise me why I cannot copy to either drive and how to correct this problem?

    Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Feb 2006
    Posts
    68
    Right click the icon for each drive, and in the menu that pops up, select: Properties> Permissions> change all permissions to>can read and write, and click on >is executable. Now click on : Device> uncheck read only. click on ok. Now when you highlight the drive, at the bottom of the box it should say> writeable: Yes . Mount the drives, and you should be able to copy files now.

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    2

    thanks - but not 100% successful

    I tried what you said, but had only partial success. Additional information:
    When the external drive is mounted, a message appears saying the drive was mounted dirty.
    If I try to copy a folder containing files and subfolders (by opening two windows and dragging-and-dropping), a few of the subfolders are created on the target, but then I get the message:
    Could not make folder /media/hdb1/james/My Documents/filelib (or other folder)
    If I go inside a folder, select all files and try to copy them, a few do get copied, but then I get a message "could not write to ..." with fully qualified file name
    If I try to copy a single file, the file is copied, but I get the message "could not change permissions for ..." with fully qualified file name.
    I have dozens of folders containing thousands of files, so copying little-by-little won't be feasible. What is going wrong here? Would a command prompt do the copy more efficiently; if so I need help in formulating the command.

    Thanks again for your anticipated help!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2006
    Posts
    68
    Ok, try this. Dont mount the drive that you want to copy to. Mount the drive that youre copying from, and drag the files and drop them on the icon of the drive that you want to copy to. From the menu that pops up, select >copy here. After the files are copied, You may still get a dialog saying that the permissions for that file couldnt be changed, but the files should be at their destination intact. Knoppix is(and most any other os) still a work in progress, and still has a few bugs.

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi geistman !

    plug-in External Harddisk and execute this command in terminal/konsole
    Code:
    su -
    fdisk -l
    post output here.






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    Just Joined! Danny Lawson's Avatar
    Join Date
    Dec 2006
    Posts
    17
    I think geistman forgot to post the output here.I 'm really excited to see the end result after using the fdisk -1 command

  8. #7
    Just Joined!
    Join Date
    Dec 2006
    Posts
    62
    This may not be related, but I tried to recover files from a Win XP Pro HD (NTFS) using Knoppix.

    I could mount and copy to USB thumb drives but not large (150 GB) Fat32 drives.

    Is this a know size restriction in Knoppix?

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    no ! there isn't any size limit. whats the error message it throws?






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #9
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    Similar prblm, within LiveCD, above suggestion does no help

    I have a similar problem-Actually in my case files did move/get copied and then they just stopped doing so. The error message being: 'Could not write to media (and if folder is trying to be copied msg is 'could not make folder').

    All of my drives did and do have Properties> Permissions> can read and write.
    However, above it says, 'click on >is executable." In my case there is no such thing anywhere--neither any of what follows: " : Device> uncheck read only. click on ok. "
    Nor does it have "Now when you highlight the drive, at the bottom of the box it should say> writable: Yes ." In my case at the bottom it says, "39G Media/ Mounted Removable Medium"

    The drive is called (by knoppix) '39G Media' which is attached to the PC via 1394 on the drive side and by USB on the PC end.
    Here's the odd thing, If i R-click on Properties of the '39G Media' it says, 'size 4.8 GB' but at the bottom it says, "free disk space 32.GB out of 37.2GB." An obvious discrepancy. So somehow, if I';m reading correctly, a part of Knoppix knows its a 39GB drive, hence why it named it so, knows that there is a lot of free space but another part of knoppix thinks there is only 4.8GB. Therefore it is not writing because it assumes there is no more space. Am I correct?
    Anyhow, do u know what I can do?

    Thank you, truly, for any advice whatsoever

    X-tra info should it help:
    On the "Console Terminal Program' I tried the command above, 'su - (which seemed uneccesary for it brought me back to where I was then did 'fdisk -l'
    and what I got was:

    Disk /dev/sda: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 5482 44034133+ 7 HPFS/NTFS
    /dev/sda2 * 5483 19457 112254187+ f W95 Ext'd (LBA)
    /dev/sda5 5483 13514 64517008+ 7 HPFS/NTFS
    /dev/sda6 13515 16486 23872558+ b W95 FAT32
    /dev/sda7 16487 19457 23864526 b W95 FAT32

    Disk /dev/sdb: 20.4 GB, 20485785600 bytes
    255 heads, 63 sectors/track, 2490 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 2490 20000893+ c W95 FAT32 (LBA)

    Disk /dev/sdc: 40.0 GB, 40007761920 bytes
    255 heads, 63 sectors/track, 4864 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdc1 2 4863 39054015 f W95 Ext'd (LBA)
    /dev/sdc5 2 4863 39053983+ 7 HPFS/NTFS

    Now, within Konqueror, under 'system/media I have:

    (D)2nd Drive [which i know is; sda5]
    (E)3D Drive [which I know is; sda6]
    (F)4T Drive [which I know is; sda7]
    20G Media [which I know is; sdb1]
    39G Media [which I know is; sdc5]
    45G Media [which I know is; sda1--and I believe is actually my original C: Drive within Windows XP NTFS}
    Blank DVD+R
    KNOPPIX

  11. #10
    Just Joined!
    Join Date
    Feb 2007
    Posts
    1
    For those still interested, this worked for me after having similar problems:
    Right click on the drive that you want to copy the files to, and select "change read/write mode". Make sure you have all handles to the drive closed before doing this. Worked for me, copied all 10 gigs over without a problem.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •