Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I was copying files from a corrupted windows installation onto an external drive using Knoppix. Everything was going great until I tried to copy my outlook.pst file (it's ~700mb). ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    copy file not working


    Hi,

    I was copying files from a corrupted windows installation onto an external drive using Knoppix. Everything was going great until I tried to copy my outlook.pst file (it's ~700mb). The copy stalled about 1/3 of the way through and now I can't see the file on the original hard drive.

    Is it gone? The drive was NTFS, so it should be read only.

    Any help is greatly appreciated.

    Thanks!

  2. #2
    Linux Newbie
    Join Date
    Jan 2007
    Location
    Arizona
    Posts
    139
    What command did you use to copy? Did you have write permissions to the external drive? Were you using USB or 1EEE1394 (Firewire/iLink) to connect that drive? If you only used cp and not mv, you should be good to go.

    I have had similar problems in the past, and a 700MB .pst is a significant loss, I feel your pain.

    Is it still not visible after a reboot?

    It might help to know that unless you do something to alter that hard drive (the one that was read-only) there is a good chance that you can recover that file intact.

    You might want to look at other options:
    1) Can you take the non-booting hard drive and put it in your hard drive enclosure to read it as external on another Windows machine?
    2) Do you have enough RAM or swap space to copy the whole file to your Knoppix desktop and burn it to cd?
    3) Have you tried to import it using a Linux office app?
    4) What is the problem with booting Windows and copying that file? If your Windows problem is as simple as it not booting why not use a Windows CD to 'repair' Windows without reinstalling. If you simply fix the boot and mbr from the recovery console, you may be good to go.
    5) If your Outlook or at least the .pst, resides on a separate partition, why not install Windows? As long as you have more than one partition, you can install Windows on a separate. Windows doesn't even has to be on the first partition, as long as the mbr is in the right place. Just be sure what you are doing, I made that mistake and installed Windows on the wrong partition and wrote over my data that I intended to save.

    If none of these options will work for you, there is something called Active@ and if you pay for the full version, you can recover data, even large files like this one, in a live boot environment.

    Hope you get your emails back...

  3. #3
    Linux Newbie
    Join Date
    Jan 2007
    Location
    Arizona
    Posts
    139

    I have a similar problem...

    I am having the same problem now, almost!

    I need to do the same thing, but I haven't lost the data. I am not able to copy with my Knoppix, or write to cd/dvd. I tried as root from konsole, I started k3B as root from konsole, I tried copying to two different sda devices, all are read only, no matter what I do.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •