Find the answer to your Linux question:
Results 1 to 3 of 3
Dear all when i run by root any application i have the error Xlib: connection to ":0.0" refused by server Xlib: No protocol specified i use the gui environement KDE ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13

    Xlib: connection to ":0.0" refused by server


    Dear all

    when i run by root any application i have the error

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    i use the gui environement KDE

    thanks for your helps

    Best regard

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    You can use the xhost command to let root use your X server. xhost +root will add root to the list of authorized users. If you're on a home computer where you're the only one who uses it, or you don't mind if everyone can use it, you can run xhost + to disable all restrictions on who can use your X server.

    Another option is to install sux and use that to switch to root. It will take care of granting access to the X server.
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    Thank you for your response, its ok for me, i can use the application when i switch root without error, i installed sux on my os, its works

    Best regard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •