Find the answer to your Linux question:
Results 1 to 4 of 4
I'm trying to load a program called WorkBooth on my Toshiba TE2000. It boots from a CD which loads Linux 2.4.27 and eventually Knoppix. I boot using the following commands: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    Question Toshiba TE2000 and Knoppix Linux 2.4


    I'm trying to load a program called WorkBooth on my Toshiba TE2000. It boots from a CD which loads Linux 2.4.27 and eventually Knoppix. I boot using the following commands:

    boot: linux24 nopcmcia noapic nodma noapm acpi=off noscsi nousb noagp xdef

    I can get it to load as far as these lines:

    INIT: Entering runlevel: 5
    Using Xvesa default 1024x768x32 -mouse "dev/psaux",5 mouse
    e100: eth0 NIC Link is Up 100 Mbps Full duplex

    And then it hangs. I have the latest BIOS upgrade 1.50 for the machine, but don't have any idea where to go from here. I'm hoping to be able to use this laptop for my work, but unless it will load the program I'm sunk.

    Any help? I'm a complete Linux noob...

  2. #2
    Linux Newbie
    Join Date
    Feb 2007
    Location
    N. Ireland
    Posts
    198
    How old roughly is your Toshiba laptop? Only one distro out of 5 I downloaded works with my one!

    Tim

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    Problem solved, and here's how

    On another forum someone suggested downloading Knoppix 5.1 and seeing if the laptop would load that (the laptop is about 2 or 3 yrs old). I did, and it loaded up beautifully, no problems at all. Didn't even have to nopcmcia or nodma it.

    So then I was thinking about trying to remaster 5.1 with the WorkBooth additions, if I could figure them out. While I was looking into that when the VP of tech support called me and tried a few things, then he got their head tech guy on the phone who ACTUALLY KNEW SOMETHING about Linux and Knoppix and the whole shebang.

    This is what worked:

    boot: linux24 nopcmcia (to kill cardmgr) nodma (to kill dma acceleration, which was hanging up fstab) xsetup

    Then when it got to the point where it's been hanging

    INIT: Entering runlevel: 5
    Using Xvesa default 1024x768x32 -mouse "dev/psaux",5 mouse
    e100: eth0 NIC Link is Up 100 Mbps Full duplex

    it went to a shell where it asked whether to use xvesa xserver or xfbdev xserver. I chose xfbdev xserver, it asked a few more questions (about the mouse, P/S2 or USB) and then THE DANG THING LOADED!! Praise be to the gods of Linux!

    The tech guy and I griped for a while about how cranky this remaster is, and he told me they're getting ready to update it to use the 5.1 Knoppix and that HE's getting to write it, so it'll be tested and sure to work for everyone.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Feb 2007
    Location
    N. Ireland
    Posts
    198

    Smile

    Glad you got it sorted. Have good day!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •