Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, I have knoppix 5.0 installed in my hard drive. And I can't boot. Grub show me these 3 init options: -debian gnu/linux, kernel 2.6.17. default -debian gnu/linu, kernel 2.6.17 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    2

    I can't boot knoppix


    Hello, I have knoppix 5.0 installed in my hard drive. And I can't boot. Grub show me these 3 init options:

    -debian gnu/linux, kernel 2.6.17. default
    -debian gnu/linu, kernel 2.6.17
    -debian gnu/linux, kernel 2.6.18-4-4-486

    And when I click in any of them a message as follows shows up:
    root (hd0,1)
    File system type is reiserfs, partitiontype 0x83
    kernel/boot/vmlinuz-2.6.18-4.486
    root=/dev/sda2 ro ramdisk-size=100000 init=/etc/init lang=de apm=power-off nomce quiet lang=es vga=791
    [linux-bzimge, setup=0x1e00, size=0x127e20]
    initrd /boot/initrd.img-2.6.18-4-486
    inux-initrd@ 0x1fb340000, 0x4bb005 bytes]
    save default
    error 16: inconsisteng filesystem structure
    Before I got this message I had to shut down the computer because very often my mouse get stuck and can't type anything and even ctrl+alt+suprimir doesn't work and I have to shut down the computer by pressing the power botton, although I did it many times and didn't happen this

    I also opened an image on a ntfs partition with mozilla, and then saved it to a linux partition, maybe was this because in that moment the computer freezed and was the right moment when I have to boot

    How can I boot into linux again?

    thank you and cheers

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I think somehow, your filesystem became corrupted. Try running fsck on the HD, from the LiveCD.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    May 2007
    Posts
    2
    Thanks for the advice, it's solved now, I didn't run fsck because I have seen your message now, but I entered a disk: systemrescuecd, and then I ran gparted, it has an option to correct errors, and then I did it and could reboot

    Thanks again and Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •