Find the answer to your Linux question:
Results 1 to 3 of 3
Hi everybody! I've just acquired an external drive of 40Gb which has NTFS file system. I'm trying to save all my files and folders from the disk to the external ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Dpontes11's Avatar
    Join Date
    Nov 2005
    Location
    Gondomar, Portugal
    Posts
    68

    Read-Write access in external drive


    Hi everybody!

    I've just acquired an external drive of 40Gb which has NTFS file system. I'm trying to save all my files and folders from the disk to the external drive.

    So, to do this, I mount the drive and try to change the read-write permitions. When I do this, it doesn't let me do it because it's an NTFS filesystem, and tells me I should do this manually. I try to do this through the console:

    $ chmod 777 /mnt/sda1

    but again says it's a read-only filesystem.
    Can anyone help me with this? I really need to pass these files to a safe place, so I can format the whole disk on my laptop.

    Thanks in advance

  2. #2
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    The default NTFS driver in the kernel is read only, or at least it is risky for writing with so it is left in read only mode. There is a tool called ntfs-3g which allows writing to NTFS using FUSE. I believe there are available packages for Knoppix.

  3. #3
    Just Joined! Dpontes11's Avatar
    Join Date
    Nov 2005
    Location
    Gondomar, Portugal
    Posts
    68
    Ok, so I followed that link and it didn't really help much... all I got was that I had to compile the kernel with this package in it, but the thing is (and I should have mentioned this before) I'm using a Live CD, and therefore can't compile a new kernel with the ntfs-3g.

    is there any possibility of changing the file system in the external drive from ntfs to fat32, f.e.?

    If not, what other options do I have to take these files from my computer? I am not able to install any new OS on the computer right now due to a memory problem...

    Or, since it's not probably safe, it doesn't mean it's not possible to do it, right? so I'm wondering if there is a way to go around this issue, forcing the OS to actually write on the ntfs file system...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •