Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, this is my first post so I'll try to make it as detailed as I can. I have read a lot of information based on this problem but seem ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    2

    Hard Drive FileSystem Missing


    Hello, this is my first post so I'll try to make it as detailed as I can. I have read a lot of information based on this problem but seem to be going in circles.
    Here I go:

    I run Windows XP 90% of the time on my personal laptop. I had a fatal error crash (typical windows) and was not able to access my hard drive. I loaded Knoppix and it read my hard drive fine so I knew my information was still present. I decided to transfer my documents/pics/music to my friends Western Digital 320GB external hard drive (FYI: He had about 30 gb used on it prior to my transfer) and then format Windows.

    I plugged in the USB and started transfering my files to the EHD while I was running on Knoppix. Then I reformatted my laptops hard drive. When I was done re-installing Windows, I was un able to access the EHD via Windows or Knoppix. The hardware is detected and recognized in Windows and Linux, it just seemed like there was no partition.

    While running Knoppix, I could see it as SDA and in GParted, drive info says its available, and to the right, it says status empty. When I try to open the folder that is located on the desktop, it says it cant mount the device. The filesystem could not be determined and none was specified. GRRR!

    So i started researching and have tried many things

    First I started to mount the device by :
    mount -o rw -t vfat /dev/sda /mnt/sda
    Error "Cant read Superblock"

    HMM:
    mount -o rw -t ntfs /dev/sda /mnt/sda
    Error " Failed to startup volume: Input/output Error
    Mount failed"

    Then:
    e3fsck -f -b 8193 /dev/sda
    Error " Attempt to read block from filesystem resulted in a short read while trying to open /dev/sda
    Could be a zero-length partition?"

    GRR:
    dumpe3fs -ob 8193 /dev/sda
    Error "No such file or directory while trying to open 8193
    couldnt find valid filesystem superblock"

    So, I think ive tried almost about everything to recover all the data, or some of the data off of the EHD? I dont want to quit trying and I dont want to send it to some professionals when they will be doing the exact things ive tried. Am I SOL and will just need to bite my lip and format???

    I appreciate any information that I can get

  2. #2
    Linux Enthusiast
    Join Date
    Jul 2005
    Location
    Maryland
    Posts
    522
    Can you post the result of:
    Code:
    su
    /sbin/fdisk -l
    from Knoppix ?

  3. #3
    Just Joined!
    Join Date
    Aug 2007
    Posts
    2
    Whenever I do an fdisk - l
    It pulls up the hda1 and hda2 which are the desktops hard drive and the knoppix CD but still cant see the SDA which is the external hard drive connected via USB

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •