Find the answer to your Linux question:
Results 1 to 3 of 3
Totally new to Linux, I decided to take the plunge. I bought a new hard drive for my Sony VAIO laptop, downloaded the Debian (Woody) CD image, and proceeded to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    jkl
    jkl is offline
    Just Joined!
    Join Date
    Jul 2004
    Posts
    2

    Enabling WEP for DWL-650 on Debian (Woody)?


    Totally new to Linux, I decided to take the plunge. I bought a new hard drive for my Sony VAIO laptop, downloaded the Debian (Woody) CD image, and proceeded to install. Didn't need to recompile any kernels or the such: it seems the DWL-650 was supported by Debian (Woody) out of the box. Way to go, Debian!

    Since the net adapter is a PCMCIA card I enabled PCMCIA support when running the Debian setup. My adapter seems to be working: the LED is on when it operates. I believe the more convincing evidence is that when my nearby Windows XP laptop is using the WLAN, the linux console gets absolutely swamped with the following message:

    eth0: Undecryptable frame on Rx. Frame Dropped.

    My diagnostic of this problem is: the device driver for the pcmcia wireless card is working, but it doesn't have the WEP passwords necessary to talk with the WLAN.

    Unfortunately I don't know what other detail to include, but I'm more than willing to add info here as necessary.

    So my questions are:

    1) seeing as I'm _almost_ there, without having to recompile any kernels or anything, is there a simple configuration setting I'm missing to get WEP to work?

    2) No matter what console I log in on my new Linux box, I get the "eth0: ..." message in copious quantities. Can I convince the kernel to just scream on /dev/tty0, so I at least can edit files without the constant barrage of messages?

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    1

    you solve this?

    I have the exact same situation. (though Im not sure how to even see the eth0 or eth1
    devices.) Anyone with any ideas out there?

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Location
    Australia
    Posts
    2
    I had a similar problem a few years back with PCMCIA ethernet cards.

    I upgraded kernels, and presto.

    If it is just WEP, then check /etc/network/interfaces

    for

    wireless_essid [snip]
    wireless_keymode open
    wireless_key1 [snip]
    wireless_key2 [snip]
    wireless_key3 [snip]
    wireless_key4 [snip]
    wireless_defaultkey 1

    and add your parameters as needed

    HTH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •