Find the answer to your Linux question:
Results 1 to 2 of 2
EDIT: This is no longer an issue, and I'm not sure what solved it. Please see my second post for current, less horrible problems. Hello all, I am attempting to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    2

    Debian on Thinkpad t61 - sound, video issues.


    EDIT: This is no longer an issue, and I'm not sure what solved it. Please see my second post for current, less horrible problems.

    Hello all,

    I am attempting to dual boot Debian Etch and WinXP Pro on my Lenovo Thinkpad T61. At the moment, I'm having trouble getting GRUB installed to properly boot Debian (which as far as I know, was succesfully installed, sans bootloader.)

    These thinkpads have a hidden recovery partition that I don't want to mess with, and various articles warn to not install GRUB to the MBR as it will render this partition unusable and possibly create other issues. The solution suggested was to install GRUB to the newly created GNU/Linux root partition, copy bootgrub.bin to some removable media, boot to windows, copy the file to C:\ and tell boot.ini about it.

    However, in installing Debian, GRUB was not able to install to anywhere. (Generic, 'this fails!' messages, not sure what's wrong.) The only thing I did not attempt was installing to a floppy because I have no floppy drive. After a bit of research, I found GRUB for DOS, and copied the neccesary files to c:\. I can boot into GRUB now. BUT I can't figure out how to add Debian to the boot list. Playing around in the grub commandline tells me that the filesystem on (hd0,1) is of type ext2fs; I assume this is the Debian partition. The following is the stanza I have added to menu.lst

    Code:
    title Debian
    fallback 0
    root (hd0,1)
    chainloader +1
    This shows up fine in the GRUB menu, but selecting it just gives me a string of repeating errors, the gist of which is I believe, "Invalid or unsupported executable format" (Really hard to tell, the text scrolls by too fast.)

    Where should I go from here?

    Thanks for your time,
    -Stacy.
    Last edited by Aniviel; 10-14-2007 at 04:25 AM. Reason: Nature of problem changed

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Posts
    2

    Update

    Bah, I don't know what was screwing up. I used gparted to erase the Debian partition, reinstalled, and GRUB could install to the Debian partition just fine. At the moment, I am accessing THAT grub through the grub-for-dos that was previously set up; the entry above worked just fine on the first boot. (I know this is ridiculous; but atm I don't want to boot primarily to the debian partition because of AHCI/compatibility mode issues as explained below.) On to current problems:

    X initially gave me "no screen found" errors; using vesa drivers gets it up and running. Can someone guide me through getting nVidia drivers to work? I have an nVidia Quadro. I'll provide more detailed info if needed; I just don't know what is wrong at the moment and don't know where to go.

    Another thing: to get the debian installer to recognize my cd-rom, I had to put SATA in AHCI rather than it's normal Compatibility mode (which my 32-bit windows needs, as this is a 64-bit machine.) Trying to boot to debian in compatiblity mode just hangs after the line, "Attached SCSI removable disk sda." Is there any way to remedy this, or will I just have to deal with switching between AHCI/Compatibility?

    Finally, Debian gives me no sound. I have not looked in to this at all; it is late and I'm tired. If this is common and has a simple solution, please explain. If not, don't bother until I've played around a bit.

    Thanks!
    -Stacy
    Last edited by Aniviel; 10-14-2007 at 04:30 AM. Reason: Clarification

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •