Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005

    FYI: Linux on a Vaio VGN-TZ21

    Just thought I'd share my limited experience on this brand new, rather expensive mini laptop. I'm a SuSE fan, but couldn't get 10.0 to work at all, the display driver just wouldn't work on the Intel chipset.

    Ubuntu 7.04 however worked straight away with no tweaks or adjustments whatsoever - and 7.04 isn't even the latest version. It is much faster than the non-working SuSE was and much much much faster than the Vista that came with it!!

    So if you have this laptop, give Ubuntu a go....

    HTH, Nick

  2. #2
    Hello, i'm just dabling with linux for the first time & on the TZ21.

    Do you get wireless networking to work ok ?
    I'm trying to access my internet connection on a wireless router; so far i've only been able to connect via a wired connection

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Well presuming you are using Ubuntu 7.04 or later I can confirm it works. So, what about the Sony Wireless Manager in Vista? If you have ever turned the wireless off in Vista, it turns it off at the hardware (bios?) level and it is off for ever until you turn it back on using the same program (or bios?). I fell foul of that when the wireless stopped working on Ubuntu. I'd turned it off in Vista and it stays off despite reboots or despite starting another OS. Might be worth checking...

    HTH, Nick

  4. $spacer_open
  5. #4
    Quote Originally Posted by NikTheGeek View Post
    Well presuming you are using Ubuntu 7.04 or later I can confirm it works.
    ok.. i was using 6.1 before.
    I just tried again with 7.10 running the live CD, and hey presto everthing worked including the wireless networking. Very nice indeed.

    Disaster struck on trying to install this to the HD. I must have made a mistake during partitioning (clashing with previous 6.1 install to the HD..?) -

    now my cherished laptop is in the following state..

    [1] booting without a CD shows the vaio logo (bios screen) then this error:-

    GRUB Loading stage1.5

    Grub loading, please wait
    Error 15

    [2] Booting Ubuntu7.1 from the live CD fires it up in 640x480 in the top left corner, with the "install" dialogues too big to fit on this screen.

    Any advice? Seems to me like I should just be able to format the drive and start from scratch.
    I'd be content with just ubuntu installed, I've no need for vista on this machine.

  6. #5

    So now i have Fedora Core installed off a cd (using the whole HD); that runs just fine, but neither wired nor wireless networking functions. At least the laptop isn't bricked.

    I just tried the ubuntu 6.1 again.
    This is what my laptop can do, in it's current state..
    [1] boot Fedora Core from the HD - graphically fine but no networking;
    [2] boot Ubuntu 6.1 from the CD - fine graphically, acess WIRED networking only
    [3] boot ubuntu 7.1 from the CD - all networking.. but graphics broken (640x480 only, and lots of display flickering during boot up)

    so frustrating since 7.1 was doing everything just fine off the CD 4 hours ago

    I guess i should try and look for howto's on Fedora wireless networking, at least i know i've seen linux can access my hardware.

  7. #6
    Finally sorted this with fedora, i discovered how to activate nm-applet.
    a little happier with my machine now...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts