Hi all,

I have a laptop (Compaq Evo N1000v) with a graphics card of ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] with 32MB memory. I'm running Fedora 8, and the auto-installed X driver is "radeon".

My problem is that whenever I switch from the default graphics mode (1400x1050@60Hz) to any other mode, and specifically to text mode, the LCD screen displays a white stain that expands and engulfs the entire screen, making it completely white (kind of a fade-to-white effect). However, when I switch back to graphics mode, the display is resumed perfectly with the graphic desktop environment. The machine does not freeze or crash.

To make sure this is not a hardware problem, I ran X with the "vesa" driver, and it worked smoothly for all mode switch operations, although this driver yields (not surprisingly) lower performance in 3D, as I measured with the glxgears app.

I attached the configuration and the log files of both vesa and radeon. One thing I noted is that the radeon driver operates on all 3 outputs of the card: the LVDS (which I believe is the LCD screen), the CRT (the external VGA connector) and the TV (which is the external S-Video connector). I also inserted "@@@@@" strings in the logs at the places where the mode-switch took place. It seems that the "radeon" driver performs "RESTORE" operations on all the outputs when it comes back to graphics mode. However, when it switches to text mode, it does not "RESTORE" the LVDS, just the TV and CRT outputs (I think). Can this be somehow attributed to the fade-to-white problem I mentioned above? Alternatively, can anyone suggest a way to make the "radeon" driver work properly?

Note that the "vesa" driver does not log any meaningful operation on the graphics card at all during mode switch - just switch the Synaptics touchpad on and off.

I have also tried various combinations (from man-pages and web sites) of both radeon-specific and generic options in the xorg.conf. None of these combinations solved my problem. Last but not least: the "ati" driver has the same problem as the "radeon" driver.

Erez Hadad


Radeon configuration

Radeon log

Vesa configuration

Vesa log