Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, I recently purchased a HP Pavilion dv9645ed laptop and I'm having nothing but problems with it. First thing after i removed the preinstalled Vista i tried to install Ubuntu ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Ozzi's Avatar
    Join Date
    Mar 2007
    Posts
    48

    HP Pavilion dv9645ed & linux


    Hi, I recently purchased a HP Pavilion dv9645ed laptop and I'm having nothing but problems with it. First thing after i removed the preinstalled Vista i tried to install Ubuntu Gusty. The setup went fine but when I restarted the computer Ubuntu wouldn't start and give me this error:
    Code:
    ahci 0000:00:0f.0: AHCI 0001.0000 32 slots 4 ports 3 Gbps 0xf impl
    SATA mode ahci 0000:00:0f.0: flags: 64bit ncq pm led clo pmp pio slum
    part ata1: SATA max UDMA/133 cmd 0xE0804D00 ctl 0x0 bmdma 0x0 irq 201
    ata2: SATA max UDMA/133 cmd 0xE0804D80 ctl 0x0 bmdma 0x0 irq 201
    ata3: SATA max UDMA/133 cmd 0xE0804E00 ctl 0x0 bmdma 0x0 irq 201
    ata4: SATA max UDMA/133 cmd 0xE0804E80 ctl 0x0 bmdma 0x0 irq 201
    scsi0 : ahci
    ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    ata1.00: ATA-7, max UDMA/133, 625142448 sectors: LBA48 NCQ (depth
    0/32) ata1.00: ata1: dev 0 multi count 16
    ata1.00: configured for UDMA/133
    ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    ata1.00: ATA-7, max UDMA/133, 625142448 sectors: LBA48 NCQ (depth
    0/32) ata1.00: ata1: dev 0 multi count 16
    ata1.00: configured for UDMA/133
    scsi1 : ahci
    ata2: SATA link down (SStatus 0 SControl 300)
    scsi2 : ahci
    ata3: SATA link down (SStatus 0 SControl 300)
    scsi3 : ahci
    ata4: SATA link down (SStatus 0 SControl 300)
    ...
    After a ton of internet searches I found that my error is a hardware problem:
    Quote Originally Posted by Wikipedia
    AHCI controller does not work on AMD/ATI RS400-200 and RS480 HBA when MSI is enabled due to a hardware error. In order for AHCI to work users must provide the "pci=nomsi" kernel boot parameter. With MSI disabled in this way, the PCIe bus can only act as a faster PCI bus with hotplug capabilities. This is also true of the Nvidia nForce 560 chipset.
    Of course the suggestion from Wikipedia had no effect on my system so I had to recompile the kermel to disable handling of MSI interrupts. Obviously after I started the new kernel nothing worked right anymore including sound and that nice Restricted Drivers Manager. OK so after a lot of more or less complete/useful tutorials and howtos I finaly get almost everything to work on my laptop.

    So all was well until I got another weird error:
    My keyboard suddenly stops responding without any particular reason. Also if I'm installing/removing packages the process freezes as well Yet my mouse is fully functional and so is the entire GUI. If I try to restart/shutdown the system then it gets to the point of "Will now halt" and then it just stops leaving the laptop running. I have to force it to shutdown keeping the power button pressed for a few seconds.

    I tried googling but couldn't find anything useful regarding this particular problem. I'm not even sure of what I should be searching for.


    If anyone has any suggestion it would be greatly appreciated. Thanks

  2. #2
    Just Joined! Ozzi's Avatar
    Join Date
    Mar 2007
    Posts
    48
    Well, I've installed the latest kernel (2.6.23.9) and still no result. I'm really running out of options.

  3. #3
    Just Joined! Ozzi's Avatar
    Join Date
    Mar 2007
    Posts
    48
    Anyone ?

  4. $spacer_open
    $spacer_close
  5. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Have you tried any other distros?

    I've heard some say that Sabayon works out of the box on lots of laptops.
    oz

  6. #5
    Just Joined! Ozzi's Avatar
    Join Date
    Mar 2007
    Posts
    48
    Wel, yes, l I have tried Ubuntu, Fedora, Debian, Kanotix and they all failed.

    Slackware and openSUSE worked though.

    Using suse now. Hasn't crashed yet.

  7. #6
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    FWIW, on any laptop I have ever had, I usually just find out what hardware it has, and compile my own kernel for whatever distro I use. That way, I have control over what is loaded, and I know what is in my laptop.

    You just have to make sure you include the critical stuff, and then you can go from there.

    Also, if I plan on running linux on a laptop, I will do a lot of homework ahead of time to make sure what I want will run. I have a HP dv2000t laptop with the Intel C2D in it, and it has an intel chipset. Everything on the laptop except for the 56k modem works on it.

    Sorry I can't help you more.

    Linux User #376741
    Code is Poetry

  8. #7
    Linux User Dark_Stang's Avatar
    Join Date
    Jun 2006
    Location
    Around St. Louis
    Posts
    284
    Hm... Ozzi, wanna give my guide a shot? The only differences between our laptops should be screen size and your graphics card (which should use the same driver anyway)
    Ubuntu on DV6636NR - Ubuntu Forums

    Edit: I mean if you still wanna try Ubuntu. Keep going with Suse if it's workin.
    Two levels higher than a newb.
    (I can search google)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •