Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Brisbane, Australia.

    Very little sound on Toshiba A100 laptop

    I have trouble getting any decent sound from my laptop with Linux.

    It's a Toshiba A100, and the model number on the back is PSAA8A-06F010. The speakers are Harman/Kardon brand. My current distro is Ubuntu 7.04 Feisty Fawn.

    I was glad to see the back end of the Windows XP it came with, and although the newest of newbies it feels like being a kid in a candy store being able to try out all the distros. Unfortunately no distros I've tried have enable me to have any decent sound. I know diddlysquat about approaching this from the programming angle, but I have tried every on-board control option I can find. Distros I have tried include Fedora, Mint, LinuxOS, Suse, Kubuntu, Edubuntu, and Ubuntu Feisty Fawn and Gutsy Gibbon. Many produced no sound at all, no matter what I tinkered with, and the best I have found is Feisty Fawn.

    At least with Feisty I can get a little bit of sound on most things, but whereas with XP the sound would have been impossibly loud with the speakers turned up all the way, so that I usually would only need them 20%, the best I can achieve with any Linux is a whisper with the volume up full, earphones plugged in, and pressed really hard to my ears. Don't think I'm doing the headphones or the speakers any good by this. Gutsy Gibbon, which I recently had upgraded to, was even worse, so I've gone back to Feisty, and scoured forums.

    Can anybody help? Thanks,

  2. #2
    Add to the end of /etc/modprobe.d/alsa-base a line:
    options snd-hda-intel model=auto

    save and reboot


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts