Find the answer to your Linux question:
Results 1 to 3 of 3
Hi. I'm having a problem with my new laptop, an LG E200-ACP11V (is what it says on the back). I've tried installing the latest versions of Ubuntu, Fedora and Mandriva ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    2

    [SOLVED] Keyboard not working after boot loader


    Hi. I'm having a problem with my new laptop, an LG E200-ACP11V (is what it says on the back). I've tried installing the latest versions of Ubuntu, Fedora and Mandriva on it, but the keyboard won't work with either of those. It worked in the preinstalled Windows Vista, and it works at the boot loader because I can chose between the options there (install, live cd, and so on) but once I make a choice it stops working. Because of this I can't install either Ubuntu or Fedora. I am currently running Mandriva since that install requires no keyboard.

    I can plug in my regular USB keyboard and it works smoothly, but the built in keyboard doesn't work. I've tried looking for anything that might lock the keyboard, but found nothing. I've been looking around on Google and found some suggestions. I've tried switching USB Legacy Support off in the BIOS, as well as any other options in there which seem even remotely related to keyboards, USB or multi-core processors (since someone mentioned something somewhere about that). No results, keyboard still doesn't react.

    I've also tried setting acpi=off in the boot options, as well as turning on and off other options I could find. I've even tried all of this in various combinations, and nothing seems to help.

    I've run out of ideas, I think. I can't find any other suggestions anywhere, though it seems to be a common enough problem. Not sure if it's purely a laptop related issue, but since my regular USB keyboard works just fine I thought it might be. Anyone have any suggestions that might help? I'd really like my new laptop to work, and I don't want to revert back to Windows on this one

  2. #2
    Just Joined!
    Join Date
    Jul 2008
    Posts
    2
    I found a solution. Adding "i8042.nopnp=1 i8042.dumbkbd=1" to the boot options solved the problem. Worth a try for anyone else who might have the same problem.

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Thanx for posting solution over here. I hope you will enjoy your stay here ! Enjoy Linux and keep helping !
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •