Find the answer to your Linux question:
Results 1 to 3 of 3
Hi there, I'm using Gentoo in an Acer notebook. I've been using "mouse" driver in xorg.conf and my vertical scroll doesn't work (it used to in Ubuntu, few months ago, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    11

    Touchpad, no vertical scrolling


    Hi there,

    I'm using Gentoo in an Acer notebook. I've been using "mouse" driver in xorg.conf and my vertical scroll doesn't work (it used to in Ubuntu, few months ago, so I know I can do it). I've installed the proper synaptics driver, and although I can use it as much as I could before, I am not able to vertical scroll yet...

    My xorg.conf revelant lines:

    Section "ServerLayout"
    Identifier "X.org Configured"
    Screen 0 "Screen0" 0 0
    InputDevice "mouse1"
    #"CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    Option "AIXGL" "true"
    EndSection

    (I commented out CorePointer. With him startx wouldn't start)

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "Synaptics"
    Option "SendCoreEvents"
    Option "Protocol" "auto-dev"
    Option "SHMConfig" "on"
    Option "VertEdgeScroll" "on"
    Option "VertScrollDelta" "100"
    Option "RightEdge" "700"
    Option "UpDownScrolling" "on"
    EndSection

    (I had no idea what values to use on RightEdge or VertScrollDelta so I tried some random values. I also tried 5400 on RightEdge once but... Nothing right.)

    Any ideas? Thanks!

  2. #2
    Just Joined!
    Join Date
    Jul 2008
    Posts
    11
    Done!

    I used Ubuntu Live CD (in which touchpad worked) and copied livecd's xorg.conf touchpad lines, which are like this right now:

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "synaptics"
    Option "SendCoreEvents" "true"
    Option "Protocol" "auto-dev"
    Option "Device" "/dev/psaux"
    Option "VertEdgeScroll" "on"
    EndSection

  3. #3
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Before xorg.conf became auto generated I always added

    Option "ZAxisMapping" "4 5"

    to get the scroll working.

    Give it a go as well as the "auto-dev" that Peter has posted.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •