Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Dear all, my name is Antonello, from Italy. I am writing you because I have some troubles in setting the italian keyboard on the Acer One. Recently, I have bought ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    1

    Keyboard on Acer Aspire One / Linpus


    Dear all,

    my name is Antonello, from Italy. I am writing you because I have some troubles
    in setting the italian keyboard on the Acer One.

    Recently, I have bought a new laptop, Acer One, which runs a linux-based OS
    --linpus-- and the windows manager Xfce. By default, the english keyboard is
    settled, even though there is the possibility to switch on different keyboards
    just clicking a keyboard-shaped icon placed on the bottom left of the screen.
    Unfortunately, this method works only partially. For instance, if you switch on
    the italian keyboard, small letter such as ... are not available. Moreover, the
    row of symbols above the numbers are still configured in english. I mean:

    ==========
    !@#$%^&*()
    1234567890
    ==========

    instead of:
    ==========
    !" $%&/()=
    1234567890
    ==========

    Surfing the web, I discovered that it should be possible to modify the keyboard
    on Xfce just editing the xorg.conf file placed on the following path:
    /etc/X11/. In particular I have modified the lines:

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    Option "XkbVariant" "euro"
    Option "XkbOptions" "grp:alt_shift_toggle"
    EndSection
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    in:
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "it,us"
    Option "XkbVariant" "euro"
    Option "XkbOptions" "grp:alt_shift_toggle"
    EndSection
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Unfortunately, it still does not work! Now, my question is: is the keyboard
    setting manager Xfce? Or, shall I look somewhere else, for example in:
    </home/user/.scim/user-tables/italian.bin>?

    Thanks in advance for your help.
    I look forward to hearing from you soon.

    Kind Regards,

    Antonello

    PS: please find enclosed the following files:
    i) /etc/X11/xorg.conf
    ii) /home/user/.scim/user-tables/italian.bin

  2. #2
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    Hello Antonello, I've the same problem too, but I found the solution in a German forum. Now I try to translate it to English for you.

    In the Data: /etc/sysconfig/i18n
    muss have this input.

    LANG=de_DE.UTF-8
    LANGUAGE=de_DE.UTF-8

    The de_DE is for German. For Italian should be it_IT ?. I'm not sure, I hope you know it.

    To change the data you've to login into the root terminal (with order 'su').
    Dann with another order
    mousepad /etc/sysconfig/i18n
    The data above will be opened, then change the first two lines to it_IT (Italian).
    After that save the whole thing. The problem of the keyboard will be solved after restarting the notebook.

    Here is the link to the original German text. I hope it helps.
    Eee PC Forum &bull; Thema anzeigen - Sprache und Tastaturbelegung falsch

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    86
    The KDE graphical interface in KDE 3.5 would offer the following solution:

    KMenu
    Control Center
    Regional & Accessibility
    Keyboard Layout
    Layout
    Add/Remove
    Apply

    As far as I know, it is possible to get and install KDE 3.5, without having to get a new operation system. Just go to the KDE website for more information.

  4. #4
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    thank you hankeat, this is just what i was looking for.
    but now i am having truble to install apps and show them on the menu. (for example: skype)

  5. #5
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    Here is the link of the solution.
    The Acer Guy Getting Skype on the Aspire One

    If it's too complicated. He shows part of the setting in youtube. Here is the video.
    YouTube - Acer Aspire One Advanced Mode

  6. #6
    Just Joined!
    Join Date
    Aug 2008
    Posts
    2

    cant save file

    Hi,
    ive done all the steps...but when i change the i18n file and try to save it appears a window saying that "Cannot open file to write"
    what im suposed to do?

  7. #7
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,116
    Go to i18n file and right click and select properties and select permissions and change from read file to read and write.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  8. #8
    Just Joined!
    Join Date
    Aug 2008
    Posts
    2
    even when i login as the root user "su root" . the i18n file doesnt let me change the permissions. help asap plz bcuz i need to work in this computer : (

  9. #9
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    Did you key in your password after you entered 'su'?

  10. #10
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3

    use vi editor

    Quote Originally Posted by Denise View Post
    even when i login as the root user "su root" . the i18n file doesnt let me change the permissions. help asap plz bcuz i need to work in this computer : (
    i had the same problem and i edited the i18n file with vi editor.
    you need to use your Terminal and some commands:
    1 open you terminal an type: cd
    2 cd /etc/sysconfig
    3 su and then your password
    4 vi i18n
    this will open the file with vi
    5 type "i"
    6 edit you file
    7 press ESC and then ":wq"
    8 reboot
    this is all

    thank you guys for the help.
    Last edited by managereda; 08-29-2008 at 07:08 PM. Reason: error

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •