Find the answer to your Linux question:
Results 1 to 3 of 3
I just picked up one of these at Target, for $299.99 USD. I'm making my first post with it. The system specs are: Intel Celeron M CPU 900MHz 512MB RAM ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    EeePC 900


    I just picked up one of these at Target, for $299.99 USD. I'm making my first post with it. The system specs are:

    Intel Celeron M CPU 900MHz
    512MB RAM
    4GB hard drive
    Linux OS (Xandros?)
    Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

    I have already modified it so that it has a KDE desktop. The problem that I have is that it defaults to the original desktop. I have to select the logoff button, and then select the 'Full Desktop' button before I get the KDE desktop.

    Does anyone know a way to make it start the KDE desktop by default?
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,844
    Go to 'Settings' and 'Personalisation'. Find 'Login Mode' and select 'Full Desktop Mode', which should be there if you have kde kicker installed.

    This isn't how I did it, btw (it's not so straightforward to do the full desktop stuff on the 901). I did it by installing Fedora 9 on an 8GB SDHC memory card, and now I can choose Gnome or KDE.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Thanks, but I already got it working. I forgot that I even posted about it.

    I basically followed the instructions found here:
    http://wiki.eeeuser.com/howto:getkde

    I don't recall having to add any repositories first, but I may have. Then I opened a terminal with the Ctrl+Alt+T keys. To get root privileges I used this command:
    Code:
    sudo bash
    I am looking at my terminal history for what I did. It looks like I had trouble with apt, so I started Synaptic from the terminal. I think that I then added this repository.
    Code:
    URI:  http://xnv4.xandros.com/4.0/pkg/
    Distribution:  xandros4.0-xn
    Section(s):  main contrib non-free
    I then installed these programs using Synaptic.

    kicker
    kmserver

    To get it to boot into the KDE desktop, I followed these instructions:
    http://wiki.eeeuser.com/howto:getkde...le_boot_effect

    I created a hidden file in my home directory named .xinitrc containing this.
    Code:
    #Needed to get automount working
    xhost + si:localuser:root
    sudo rm /tmp/nologin
     
    #Needed to get the network working
    sudo /opt/xandros/bin/start_netserv &
     
    startkde
    This seems to work OK, but I still need to disable the popups for my SD card at boot. There is a way to do that too, it seems
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •