Find the answer to your Linux question:
Results 1 to 3 of 3
Hello guys, I 've just bought a sony vaio FW21M laptop and tried to install linux. Distros i tried: Ubuntu, OpenSuse, Fedora, Gentoo. All were the latest versions. 1st) Ubuntu: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    5

    Linux && Vaio FW Series


    Hello guys,
    I 've just bought a sony vaio FW21M laptop and tried to install linux.
    Distros i tried: Ubuntu, OpenSuse, Fedora, Gentoo.
    All were the latest versions.

    1st) Ubuntu: All working perfectly except the FN keys for adjusting the bightness, and the power management didn't work at all. I could live with it but i don't like the name :P
    so....
    2nd) OpenSuse: Graphics don't work, wireless don't work.
    3rd) Gentoo: No graphics again.
    4th) Fedora: Can not install. Some problem freezes the screen before the installation. [Although, the first time i tried, the live version started!]

    Have anyone installed linux on a FW-series laptop? What distro should i use??
    help me please

  2. #2
    Just Joined! JosipBroz's Avatar
    Join Date
    Dec 2008
    Location
    Ljubljana
    Posts
    17
    Hilarious! You switched distros because you didn't like the NAME?!
    Anyway, I can only speak for openSUSE as I don't know the other distros enough: your graphics and wireless are supposed to not work. Now, that may sound strange, but it's not: since the respective drivers are closed-source, they can never be distributed in a Free-software GNU/Linux distro such as openSUSE. They can be installed, though, from community depots, the procedure being just a tad convoluted. I suspect the problems with the other distros you mention might be of a similar nature: they are due to hardware vendors, not to GNU/Linux as such.
    The distros you tried may be well suited for you, the thing to do is boot the live CDs in text-mode only or plain vanilla vga/vesa/framebuffer drivers and the like. Each distro should have specific release notes on their web sites.

  3. #3
    Banned
    Join Date
    Jan 2008
    Posts
    79
    Which graphics chip were you running? I think a lot of Sony Vaio laptops have the hybrid graphics. Try going into the bios and use the Intel X4500 and see if that will be accepted?

    For the wireless, I think a lot of the newer Vaio laptops use the newer Intel 5000 series wifi chips. They are problematic for kernels of 2.6.26 and below. You either need to compile for the wireless chip or use a distro with a later kernel like 2.6.27. I read the support is supposed to improve for kernel 2.6.28.

    I would try a distro with kernel 2.6.27+ and see if the wireless will work. Did you try Ubuntu 8.10?

    There are probably writeups for the power management and maybe the FN keys. I don't know about that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •