Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Hey. I have recently bought acer aspire one netbook, for college work mainly. to my dissapointment it READS from my usb stick but it will not WRITE anything to it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6

    [SOLVED] Linpus linux not write to NTFS or Read FAT?


    Hey.
    I have recently bought acer aspire one netbook, for college work mainly. to my dissapointment it READS from my usb stick but it will not WRITE anything to it at all. It wont even let me drag files to it, only from it.
    This is one of the reasons i needed this notebook.. now i think i am going to install windows unless somebody can please help.
    I have installed that 3g thingy, to no availe. It will write to a SD card, just not my NTFS usb stick.
    It wont even read my Fat or Fat32 usb sticks...

    Any help will be greatly taken... sorry for bad english..

    Jaime

  2. #2
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Can you tell us the error message you get?

    This might be a permissions issue.....
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6
    well when i insert my usb pen into the computer i get a message bottom right of my screen that says,
    "this version of linux on this netbook only supports read from NTFS" or something similar.. The "paste" is greyed out if i try and copy and paste something to the usb drive. but here are the error messages when i try to save a .txt file

    Error saving the document test: /media/Jamie/test.odt does not exsist

    then i get another

    Error saving the document test:
    General Error.
    General input/output error.

    when i right click on my usb stick (named jamie) it says:
    Owner:root(root)
    Access: Read and Write (but it is greyed out.)
    the rest of other options, group(root), access and others (Read and Write) are also greyed out.

    Whereas my SD card and HDD are not greyed out but come under user.

    I can login to terminal as SU and then password.. but do not know how to get access to try coping files to my usb stick as root...

    hope this information is clear, sorry for english..

    jamie

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast L4Linux's Avatar
    Join Date
    Sep 2008
    Location
    Greece
    Posts
    583
    When you become root and go to the usb (it should be in /media/) can you create a folder?
    Code:
    mkdir test
    If it creates a folder named test, then it is a permissions issue.

  6. #5
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    From the error message, it looks like it's *not* a permissions problem. You say you've installed ntfs-3g, is that correct?

    Have you also installed fuse and fuse-libs?
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  7. #6
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6
    L4Linux - I cannot create a directory in "Jamie"(the usb). It says its a read-only file system.

    I can create one in /media/ but i dont see how that helps.

    smolloy - I am pretty sure i have installed "ntfs-3g" but not so sure about the others, although a quick check of the add programs lists fuse-libs.

    Not too sure, ill check see if i can find a download for them again..

    I got told on another forum to try FAT and FAT32, but when i plug my 1gb usb drive in either of those formats, it doesnt even recognise i have plugged one in.

    PS the message when i insert my NTFS pen in says
    " The Jamie drive is ready for use now. However, this notebook supports read-only access to NTFS drives. Please save your files to a different drive."

    Yes because thats helpful ......

    Can you guys tell me the menu where i set whether it mounts the media on plugging it in? Iv heard somebody mention it but cant find the menu.

    thanks for fast replies..

  8. #7
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    OK, I did a bit of hunting around (Google is your friend) and found out that installing ntfs-3g used to be enough to get those little Acer's to read/write NTFS partitions, but an update managed to break that capability (it gave everyone the chance to read NTFS, but broke writing).

    You can do it manually with the following command,
    Code:
    sudo ntfs-3g /dev/sdb1 /mnt/ntfs
    Of course, before you can do this, you need to know the device name ("sdb1" in my example), and you need to make the mount point ("/mnt/ntfs" in my example).
    Last edited by smolloy; 01-08-2009 at 11:39 PM. Reason: Forgot to use sudo
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  9. #8
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Also, I've seen hints that the command "ntfs-config" might be able to sort out the permissions issue. This would let you automount it when it is inserted, without having to type the previous command I gave.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  10. #9
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6
    im new to the whole linux thing as of two days ago, and have no idea of what you mean by device name and mount point :P
    i would google this stuff.. but i dont know what to google eheheh


    I enabled write support for external devices from the ntfs-config, but this hasnt changed anything yet.


    *edit* going onto netbook to post information from there, some error logs as i found device using fdisk

  11. #10
    Just Joined!
    Join Date
    Jan 2009
    Posts
    6
    ok, sorry for double post. after some playing around with the commands you gave me, iv managed to make it so i can write to it. HURRAH.

    i didnt think they were going to work but i unplugged, and replugged the device back in and so far good.

    im copying my college work across as we speak and i will try a reboot after to see if the effect is permanent.

    will edit back with results

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •