Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all, I'm having some troubles with an AMD Geode ALX 800 processor. I installed Slackware 12.2, kernel 2.6.27.7 with no problems. After rebooting, the kernel hangs on boot process ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2009
    Posts
    2

    Post Kernel 2.6.27.7 hangs on AMD Geode ALX 800 processor


    Hello all,

    I'm having some troubles with an AMD Geode ALX 800 processor. I installed Slackware 12.2, kernel 2.6.27.7 with no problems.
    After rebooting, the kernel hangs on boot process (after LILO or GRUB) for about 20 minutes. During this time the only thing I can see is a black screen.
    After this long time waiting the kernel starts booting normally.
    I had the same problem using kernel 2.6.21 and I fixed it by replacing lilo with grub. This time I tried the same with no sucess.

    Another try I made was boot with a live CD with the last Slax version and with Ubuntu (kernel 2.6.22) live CD. The same problem happened.

    Re: Geode LX800 hanging at boot in vesa_store_edid() w/ CONFIG_FIRMWARE_EDID=y
    I tried to recompile the kernel with the option CONFIG_FIRMWARE_EDID=n, as suggested at the link above, but this option was already off.

    This link bellow shows a full description about the board I'm using.
    AMD Geode LX 800 ALXD800EEXJ2VC

    Please help me. I'm newbie.
    I tried everything what's possible to me and I can't solve this problem by myself.

    See bellow some info about my installed system. Sorry if it's so much and unnecessary information:

    #cat /proc/cpuinfo
    processor : 0
    vendor_id : AuthenticAMD
    cpu family : 5
    model : 10
    model name : Geode(TM) Integrated Processor by AMD PCS
    stepping : 2
    cpu MHz : 498.041
    cache size : 128 KB
    fdiv_bug : no
    hlt_bug : no
    f00f_bug : no
    coma_bug : no
    fpu : yes
    fpu_exception : yes
    cpuid level : 1
    wp : yes
    flags : fpu de pse tsc msr cx8 sep pge cmov clflush mmx mmxext 3dnowext 3dnow
    bogomips : 996.08
    clflush size : 32
    power management:

    #uname -a
    Linux darkstar 2.6.27.7 #2 Thu Nov 20 23:19:39 CST 2008 i586 Geode(TM) Integrated Processor by AMD PCS AuthenticAMD GNU/Linux

    #lspci
    00:01.0 Host bridge: Advanced Micro Devices [AMD] CS5536 [Geode companion] Host Bridge (rev 33)
    00:01.1 VGA compatible controller: Advanced Micro Devices [AMD] Geode LX Video
    00:01.2 Entertainment encryption device: Advanced Micro Devices [AMD] Geode LX AES Security Block
    00:09.0 Ethernet controller: VIA Technologies, Inc. VT6105M [Rhine-III] (rev 96)
    00:0c.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
    00:0f.0 ISA bridge: Advanced Micro Devices [AMD] CS5536 [Geode companion] ISA (rev 03)
    00:0f.2 IDE interface: Advanced Micro Devices [AMD] CS5536 [Geode companion] IDE (rev 01)
    00:0f.3 Multimedia audio controller: Advanced Micro Devices [AMD] CS5536 [Geode companion] Audio (rev 01)
    00:0f.4 USB Controller: Advanced Micro Devices [AMD] CS5536 [Geode companion] OHC (rev 02)
    00:0f.5 USB Controller: Advanced Micro Devices [AMD] CS5536 [Geode companion] EHC (rev 02)

    #dmesg | head -60
    Linux version 2.6.27.7 (root@midas) (gcc version 4.2.4) #2 Thu Nov 20 23:19:39 CST 2008
    BIOS-provided physical RAM map:
    BIOS-e820: 0000000000000000 - 000000000009e800 (usable)
    BIOS-e820: 000000000009e800 - 00000000000a0000 (reserved)
    BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
    BIOS-e820: 0000000000100000 - 000000000efb0000 (usable)
    BIOS-e820: 000000000efb0000 - 000000000efb3000 (ACPI NVS)
    BIOS-e820: 000000000efb3000 - 000000000efc0000 (ACPI data)
    BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
    DMI not present or invalid.
    last_pfn = 0xefb0 max_arch_pfn = 0x100000
    kernel direct mapping tables up to efb0000 @ 7000-d000
    ACPI: RSDP 000F59F0, 0014 (r0 AMDGX3)
    ACPI: RSDT 0EFB3040, 0028 (r1 AMDGX3 AWRDACPI 42302E31 AWRD 0)
    ACPI: FACP 0EFB30C0, 0074 (r1 AMDGX3 AWRDACPI 42302E31 AWRD 0)
    ACPI: DSDT 0EFB3180, 1DFC (r1 AMDGX3 AWRDACPI 1000 MSFT 3000000)
    ACPI: FACS 0EFB0000, 0040
    ACPI: no DMI BIOS year, acpi=force is required to enable ACPI
    ACPI: Disabling ACPI support
    0MB HIGHMEM available.
    239MB LOWMEM available.
    mapped low ram: 0 - 0efb0000
    low ram: 00000000 - 0efb0000
    bootmap 00001000 - 00002df8
    (6 early reservations) ==> bootmem [0000000000 - 000efb0000]
    #0 [0000000000 - 0000001000] BIOS data page ==> [0000000000 - 0000001000]
    #1 [0000100000 - 00009f3228] TEXT DATA BSS ==> [0000100000 - 00009f3228]
    #2 [00009f4000 - 00009f8000] INIT_PG_TABLE ==> [00009f4000 - 00009f8000]
    #3 [000009e000 - 0000100000] BIOS reserved ==> [000009e000 - 0000100000]
    #4 [0000007000 - 0000009000] PGTABLE ==> [0000007000 - 0000009000]
    #5 [0000001000 - 0000003000] BOOTMAP ==> [0000001000 - 0000003000]
    Zone PFN ranges:
    DMA 0x00000000 -> 0x00001000
    Normal 0x00001000 -> 0x0000efb0
    HighMem 0x0000efb0 -> 0x0000efb0
    Movable zone start PFN for each node
    early_node_map[2] active PFN ranges
    0: 0x00000000 -> 0x0000009e
    0: 0x00000100 -> 0x0000efb0
    On node 0 totalpages: 61262
    free_area_init_node: node 0, pgdat c08fda20, node_mem_map c1000000
    DMA zone: 3966 pages, LIFO batch:0
    Normal zone: 56816 pages, LIFO batch:15
    PM: Registered nosave memory: 000000000009e000 - 000000000009f000
    PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
    PM: Registered nosave memory: 00000000000a0000 - 00000000000f0000
    PM: Registered nosave memory: 00000000000f0000 - 0000000000100000
    Allocating PCI resources starting at 10000000 (gap: efc0000:f1030000)
    Built 1 zonelists in Zone order, mobility grouping on. Total pages: 60782
    Kernel command line: root=/dev/hda2 ro vga=788
    Initializing CPU#0
    PID hash table entries: 1024 (order: 10, 4096 bytes)
    TSC: Using PIT calibration value
    Detected 498.041 MHz processor.
    Console: colour dummy device 80x25
    console [tty0] enabled
    Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
    Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
    Memory: 233592k/245440k available (6139k kernel code, 11340k reserved, 2083k data, 368k init, 0k highmem)


    Thanks for advice!

    Jonatas Bessow

  2. #2
    Just Joined!
    Join Date
    Feb 2009
    Posts
    2
    Depending on the value I pass to boot in the vga parameter (ie. vga=normal) instead of a black screen I see the message "linux boot probing edd (edd=off to disable).. ok". In both cases the system hangs for about 20 minutes.

    Any idea?

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Location
    South West England
    Posts
    91
    Same as my problem on my Desktop PC. Try appending "hpet=disable" to the end of the kernel command line (hit Esc at bootup, then e, then go to the kernel entry, hit e, and append the line to the end).
    It can also be appended to the end of the line in /boot/grub/menu.lst.

    It's a HPET kernel bug fixed in 2.6.28 but not in time for Intrepid.

    Cheers
    Dan

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •