Find the answer to your Linux question:
Results 1 to 2 of 2
I'm having trouble with a terminal that serves information from a remote database to my customers. I hope the terminal is tiny enough to qualify for this forum The machine: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Posts
    2

    [SOLVED] Newbie with LiLo issues on a light terminal


    I'm having trouble with a terminal that serves information from a remote database to my customers. I hope the terminal is tiny enough to qualify for this forum

    The machine: A stripped down network terminal of unknown manufacture (model #: Light System). 400MHz processor, 256MB Ram, No HDD. Mass storage was a 1GB CF card at /dev/hdc1. OS seems to be a stripped down SuSE 2.4.x install. Bootloader is LiLo with boot options for Linux and memtest86.

    The problem: Computer boots to LiLo boot menu, then returns the following about one second into loading linux.
    Code:
    Error 0x10
    The computer then returns to the LiLo boot menu and the cycle repeats indefinately. If I break out of the timer and select the memtest86 option it runs the test program fine. If I manually boot linux it returns Error 0x10 and returns to the boot menu but does not loop.

    What I've done so far: I am booting the machine using DSL 4.4.10 on a USB flash drive. I can mount and view the contents of the CF card without obvious issue. After some reading, I tried to rerun LiLo using:
    Code:
    mount /dev/hdc1 /mnt/hdc1
    chroot /mnt/hdc1 /bin/bash
    /sbin/lilo
    Trying to reboot from the CF card resulted in a repeat of the original problem.

    Working on the assumption that the CF card had one or more faulty sectors (and hoping there wasn't a loss of important data) I copied the CF card to a separate flash drive at /dev/sdb1 using:
    Code:
    mount /dev/sdb1 /mnt/sdb1
    tar -cvf /mnt/sdb1/filename.tar /mnt/hdc1
    The final result was the tar process completed with errors, but I didn't see what errors were displayed during the process. I used fdisk to check for additional partitions but there was only one.

    I replaced the CF card with a new 4GB card and used fdisk to create the /dev/hdc1 partition and make the partition bootable. I then did
    Code:
    mount /dev/hdc1 /mnt/hdc1
    tar -xvf filename.tar /mnt/hdc1
    After completing I did
    Code:
    chroot /mnt/hdc1 /bin/bash
    /sbin/lilo
    This results in
    Code:
    Warning: /etc/lilo.conf should be writable only for root
    Warning: LBA32 addressing assumed
    Warning: '/proc/partitions' does not exists disk scan bypassed
    Added linux *
    Added memtest86
    3 warnings were issued
    I tried booting from the CF card, but there was no bootloader at all. The machine ran through the CMOS startup process, then stopped. Obviously I've missed a critical step in creating the MBR but I don't know where. Running liloconfig returns command not found, and I don't know where else to look for the MBR

  2. #2
    Just Joined!
    Join Date
    Mar 2009
    Posts
    2
    Problem... not solved but no longer relevant. I stopped using a terminal through the GUI and started booting DSL in text-only (runlevel 2) and started seeing I/O errors in many places in the directory tree. I don't think I can salvage the application the terminal is intended to run. Thanks to everyone that looked at the original post and considered my problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •