Find the answer to your Linux question:
Results 1 to 3 of 3
Is there any way to set xrandr --output s-video --set load_detection 1 by default? Every time i reboot it turns it off... also does anyone know if it possible to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! otkaz's Avatar
    Join Date
    Feb 2009
    Location
    Houston, TX
    Posts
    19

    xrandr s-video load_detection


    Is there any way to set xrandr --output s-video --set load_detection 1 by default? Every time i reboot it turns it off...
    also does anyone know if it possible to create an acpi event for when the s-video cable is connected?
    lspci | grep VGA
    01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02)
    dell 600m

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,752
    The simplest way would be to put the call in your login script (~/.bash_profile). I do that sort of thing all the time to do stuff like remote mounts of samba or nfs shares to my local file system, etc.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined! otkaz's Avatar
    Join Date
    Feb 2009
    Location
    Houston, TX
    Posts
    19
    Quote Originally Posted by Rubberman View Post
    The simplest way would be to put the call in your login script (~/.bash_profile). I do that sort of thing all the time to do stuff like remote mounts of samba or nfs shares to my local file system, etc.
    thanks for the reply
    main reason I was asking was I wrote a script to change xrandr settings on s-video. the first part of the script tuned on load detection which worked fine, but if I was already outputting to s-video and ran the script that line would give me an error. I added xrandr --auto before the load detection line and it fixed it. here is the script in case anyone is interested it requires xvattr to switch video overlay to s-video.
    Code:
    #!/bin/sh
    
    xrandr --auto
    xrandr --output S-video --set load_detection 1
    
    svideo=`xrandr | grep S-video | awk '{print $2}'`
    
    if [ "$svideo" = "connected" ]
    then
    xrandr --output S-video --mode 800x600
    xrandr --output LVDS --mode 800x600
    xvattr -a XV_CRTC -v 1
    else
    xrandr --output S-video --off
    xrandr --output LVDS --mode 1024x768
    xvattr -a XV_CRTC -v 0
    fi

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •