Find the answer to your Linux question:
Results 1 to 9 of 9
Hello! Let me start off by saying that I am a strongly intermediate linux user - I've been through multiple distributions, know how to do basic programming, and am not ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    3

    Switching Distros - Dell Inspiron 1545


    Hello! Let me start off by saying that I am a strongly intermediate linux user - I've been through multiple distributions, know how to do basic programming, and am not afraid of the command line.

    Now, for various reasons, the straw breaking the camel's back being the absolute hideousness of much of Karmic Koala, I have decided to once again move away from Ubuntu. I tried to do this once before, moving to Fedora 11, but it does not come with the required Broadcom wireless driver installed, and I have no access to a wired connection so I cannot use an rpm or yum it. I also downloaded it from the official site (sorry I'm not allowed to post URLs...), but the installation/compiling did not work for me (I do not remember the exact error as it was months ago).

    So, my question is, is there any solution to my problem that I am overlooking, or are there any distributions that come with the driver preinstalled?

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Since the wl driver is non-free, I don't think many distros ship with it by default.

    Why don't you download the rpm to a USB stick, transfer them to your Fedora box, and install 'em?
    RPM installation of Broadcom 802.11 STA wireless driver in Fedora 8/9/10 | cenolan.com

    I do a similar thing on Arch fairly frequently. Everytime there's a kernel update, I have to build the module against the new kernel. I try and keep an updated tar ball of the driver and the Arch build script for it on the computer, so when an kernel update comes through, I can build the module without an internet connection available.

  3. #3
    Just Joined!
    Join Date
    Oct 2009
    Posts
    3
    I tried that, but it is mandatory to have access to the internet to use an RPM, either that or there are some dependencies that do not ship with the system.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    You would need all the dependencies. I don't use Fedora, but I think it's just kmod-wl-<your kernel version> and kmod-wl-5.10.79.10.

    You can find them here for F11.

  6. #5
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    You could always install your distro of choice, and then boot with the Ubuntu Livecd because wireless works on it, mount your install, copy over resolv.conf, and then chroot into your install and install whatever you need to get wireless working. Your internet will work because Ubuntu is connected. I do it all the time installing Gentoo.

    Also, have you tried the Fedora LiveCD? It comes with wireless drivers that the DVD's don't have pre-installed. Don't know if it has yours or not, but it is worth a shot.

    Linux User #376741
    Code is Poetry

  7. #6
    Just Joined!
    Join Date
    Oct 2009
    Posts
    3
    Hello! Sorry to be a bother so late in the game in this thread, but I tried doing as recommended to either simply transfer the rpms over from a usb drive, or to mount Fedora from an ubuntu partition, the live disc in this case.

    Upon trying to run an rpm, I get some error (sorry, I didn't have the time, energy, nor resources to transcribe the entire thing on paper), regarding a yum xml file and the repo: fedora. It is not extremely long, but more than a few lines. At the end of it was something similar to "Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again" (caught from a quick google search using keywords).

    I also attempted to mount the Fedora partition, but following a simple guide that I found online, all it did was mount the /boot folder, and either way, doesn't solve the problem as far as I understand it.

    Sorry for being such a burden, but are there any other suggestions / tips?

  8. #7
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I haven't used Fedora in over a year so I may be a bit outdated here...you want to use a command like yum this way
    Code:
    yum localinstall --disablerepo=* packagename
    I'd try using RPM command like this.
    Code:
    rpm -Ihv packagename
    You need to be in the directory that contains the .RPM files for this to work.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  9. #8
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Quote Originally Posted by monkat View Post
    Hello! Sorry to be a bother so late in the game in this thread, but I tried doing as recommended to either simply transfer the rpms over from a usb drive, or to mount Fedora from an ubuntu partition, the live disc in this case.

    Upon trying to run an rpm, I get some error (sorry, I didn't have the time, energy, nor resources to transcribe the entire thing on paper), regarding a yum xml file and the repo: fedora. It is not extremely long, but more than a few lines. At the end of it was something similar to "Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again" (caught from a quick google search using keywords).

    I also attempted to mount the Fedora partition, but following a simple guide that I found online, all it did was mount the /boot folder, and either way, doesn't solve the problem as far as I understand it.

    Sorry for being such a burden, but are there any other suggestions / tips?
    You first have to copy your /etc/resolv.conf over to your fedora partition from the livecd or other install you have, whatever you are using.
    Code:
    cp /etc/resolv.conf /wherever/you/mounted/fedora/etc/
    Now, you will want to chroot into that environment now that you have your resolv.conf copied
    Code:
    chroot /mnt/wherever/your/fedora/is/mounted /bin/bash
    You should now be able to use the internet while chrooted into your fedora partition.

    Note: This only works if you have internet in the other environment.

    I could help you mount your fedora partition if I knew more about your layout. I could give you exact commands then.

    Linux User #376741
    Code is Poetry

  10. #9
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Quote Originally Posted by MikeTbob View Post
    I haven't used Fedora in over a year so I may be a bit outdated here...you want to use a command like yum this way
    Code:
    yum localinstall --disablerepo=* packagename
    I'd try using RPM command like this.
    Code:
    rpm -Ihv packagename
    You need to be in the directory that contains the .RPM files for this to work.
    It would be
    Code:
    yum localinstall --disablerepo=* --nogpgcheck packagename
    But, if you disable the repos, it won't be able to find the dependencies so it is really kind of defeating the purpose of doing a local install of yum unless you have all of the dependencies installed already.

    Linux User #376741
    Code is Poetry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •