Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, System: ASUS PRO50n Series Notebook Distro: Archlinux DE: Gnome I've been posting quite avidly for the past few days on various minor problems I've had since installing Arch Linux, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38

    Hang on Restart


    Hi,

    System:
    ASUS PRO50n Series Notebook
    Distro: Archlinux
    DE: Gnome

    I've been posting quite avidly for the past few days on various minor problems I've had since installing Arch Linux, most of them are sorted now apart from this last one. It doesn't matter what distro I use, I've had ubuntu, xubuntu, fedora and now Arch installed previously and I have the same issue on all of them. When I restart the laptop, it all goes fine until it reaches the part where it is about to physically restart, it just hangs there, resulting it me having to press the power button. It shuts down perfectly fine, hibernates fine, sleeps fine, just the restart that doesn't work. As i say its been the same on every distro i've used.

    I've read in places that it could be to do with ACPI settings, but non of the forums seem to give a definitive solution to this, and my bios seems to be lacking in any area allowing you to alter ACPI settings. I'm fairly certain its nothing to do with the linux install because it is unlikely to have happened on every distro.

    Has anyone got any ideas how I can go about solving this problem?


    Thanks,
    Scott.

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,037
    Have you already tried adding to the end of kernel line in Arch in /boot/grub/menu.lst.

    acpi=force
    My older IBM T23 requires this in the kernel line to reboot,shutdown, etc... properly using any Linux Distro from Puppy to AntiX because of age of bios.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    hi rokytnji,

    I've added acpi=force to menu.lst and its still no different. Have I done it right? :

    # (0) Arch Linux
    title Arch Linux
    root (hd0,1)
    kernel /boot/vmlinuz26 root=/dev/disk/by-uuid/6e3bcc79-b8aa-41d7-85f9-04c76ca967e3 ro acpi=force
    initrd
    /boot/kernel26.img
    My laptop isn't old really, its fairly new (within last 2 years)

    Any ideas?

    Thanks,
    Scott.

  4. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    This problem is not as easy as your other ones!

    Here is a post with some ideas.
    Arch Linux Forums / system hangs on restart or shutdown

    Here are some acpi kernel parameters you can try out:
    SDB:Kernel Parameters for ACPI/APIC - openSUSE

  5. #5
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    I've tried adding acpi=off to the kernal line in grubs menu.lst and still no difference.

    Are we sure that its ACPI thats causing the problem and not something else? Would you not expect the problem to stop once ACPI is turned off all together if it was related to this?


    Thanks,
    Scott.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •