Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
It's been about an hour and I'm ready to throw my computer against a wall. I'm running knoppix off a cd and am becoming enraged by the tap to click ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2010
    Posts
    5

    Help me kill tap-to-click before my laptop


    It's been about an hour and I'm ready to throw my computer against a wall. I'm running knoppix off a cd and am becoming enraged by the tap to click on my Compaq nc6000 laptop. xorg.conf doesn't exist in my X11 folder (and I can't save those files anyways), and the mouse settings are very basic.

    I'm a huge linux noob, so I generally need to be walked through everything...

    Thank you in advance : )

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Welcome to LinuxForums!

    Could you clarify a little for us?
    Are you having trouble enabling tap to click, or disabling?

    That setting should be somewhere in a Preferences menu... either Mouse Preferences or perhaps Trackpad Preferences.

    As far as saving your settings... you're correct. Since you're running off of a LiveCD, you'll need to make this adjustment for every session after startup.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Just Joined!
    Join Date
    Jun 2010
    Posts
    5
    I'm trying to disable the sucker, it is enabled by default.
    Many settings will claim that a restart of KDE is needed to save them. The mouse settings have no options for the trackpad, and I can't find trackpad settings either.

  4. #4
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    I haven't played with Knoppix in a bit.
    Let me dig out a disc and I'll see if I can find anything different.

    What version are you running?
    And do you have the CD version? Or the DVD?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  5. #5
    Just Joined!
    Join Date
    Jun 2010
    Posts
    5
    I have the CD version. I downloaded it yesterday, so I'd just assume the English release of the most recent version.

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,558
    Tap-to-click - tap on laptop touch pad to "emulate" a right-button click. I like it myself, but I can agree that there are times when you might want to disable it. If you do a regular installation, you should be able to disable (sic) it from the system prefernces menu of the desktop GUI.

    I have a similar (but different) problem with my Dell D630 laptop. Touching the case near the bottom of the unit will often "simulate" a button click, even with tap-to-touch disabled, resulting in undesirable behavior quite frequently for me. It does the same thing with Windows running on the same laptop, so it has to be a hardware glitch. I never had the problem with Windows or Linux on my old D600... It's been driving me batty for a couple of years now. Between that and the multiple battery failures on the unit, I think I'll look into other laptops for my next one.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #7
    Just Joined!
    Join Date
    Jun 2010
    Posts
    5
    I made some progress, but cannot find a code that actually disables it. If I save my Knoppix config on my thumbdrive, I can extract it and add a modified config file back into it and load that on the next restart using this code

    Code:
    bunzip2 /mnt/sda1/configs.tbz
    tar -rpPf /mnt/sda1/configs.tar /home/knoppix/Desktop/XF86Config-4
    BZIP2=-9 bzip2 /mnt/sda1/configs.tar
    mv /mnt/sda1/configs.tar.bz2 /mnt/sda1/configs.tbz
    Like I said though, Adding a synaptics module with MaxTapTime at 0 or with Trackpad Disabled set to 1 does nothing.

  8. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,558
    It's conceivably possible that there is a bios (hardware) setting that turns multiple taps into clicks. Have you looked at the bios settings to see if it can be disabled there? Just so you know, this is just a SWAG (Stupid Wild-Assed Guess), but since I am running out of ideas...
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  9. #9
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    I didn't see a GUI setting, either...
    I'm out of ideas at this point.
    I would go with Rubberman's suggestion... check for a possible BIOS setting.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  10. #10
    Just Joined!
    Join Date
    Jun 2010
    Posts
    1
    Have you tried this from a terminal as user?

    Code:
    synclient TouchpadOff=1
    This works well in my wife's laptop.
    --
    Neal

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •